Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Themes

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

strange error msg


Reply

5 Posts   1348 Views

Avatar
mdm

18 February 2009 at 6:57am Community Member, 19 Posts

When i visit my site now i get a msg like this:

Warning: scandir(/themes/_config.php) [function.scandir]: failed to open dir: Not a directory in /sapphire/core/ManifestBuilder.php on line 272

Warning: scandir() [function.scandir]: (errno 20): Not a directory in /sapphire/core/ManifestBuilder.php on line 272

Under it i see my page but its distorted.
When pressing F5 its back to normal.

Ideas?

Avatar
Ultimate

18 February 2009 at 9:02pm Community Member, 18 Posts

It's a pretty common error.

It can occur if you changed your projectname in _config.php, but did not changed the name of the project-folder. Maybe you let it by "mysite". But those names have to be the same.

Avatar
mdm

18 February 2009 at 9:11pm Community Member, 19 Posts

in config i changed template from blackcandy to my name i have, and folder is named the same.
strange error to accure since its working and i see template under this msg, but the site is aligned left. pressing F5 and its all perfect and no error msg.

Looking right now and didnt get this msg but I do get some XML error but im to fast with reflexes so my hand went to F5 before i had the chance to copy it - im a bad surfer.

If I change back to blackcandy in _config.php its all good. change to "atten4" witch is the tempalte dir name i get this msg but just sometimes. confusing really.

Avatar
Ultimate

19 February 2009 at 5:50am Community Member, 18 Posts

Sorry this did not work for you, but it helped me some days ago.

Just take a look into other threads, e.g.
[url]http://www.silverstripe.org/themes-2/show/251691?start=0[/url]

Avatar
mdm

19 February 2009 at 6:17am Community Member, 19 Posts

I noticed something today when making final things on the design. mysite and template dirs had both _config files in them, removed from template dir and its okey now :)

www.atten4.se
added to showcase aswell

love this cms - woho! so simple to make my own design work perfect.
Challange will now be to make more advanced stuff but this was a good start to learn.