Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Themes /

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Downloaded Themes Not Working....


Reply


7 Posts   3180 Views

Avatar
Thyestean

Community Member, 2 Posts

4 March 2009 at 10:40pm

Hey there,

I downloaded on of the themes off the site just to check it out but there seems to be a problemo.... and it looks like this....

"

[Warning] None of these templates can be found: Page.ss, ContentController.ss
GET /ss/merch/?stage=Live

Line 171 in C:\wamp\www\ss\sapphire\core\SSViewer.php
Source

162                $this->chosenTemplates['main'] = $this->chosenTemplates[$templateFolder];
163                unset($this->chosenTemplates[$templateFolder]);
164             }
165          }
166
167          if(isset($_GET['debug_request'])) Debug::message("Final template selections made: " . var_export($this->chosenTemplates, true));
168
169       }
170
171       if(!$this->chosenTemplates) user_error("None of these templates can be found: ". implode(".ss, ", $templateList) . ".ss", E_USER_WARNING);
172
173       parent::__construct();
174    }
175    
176    /**
177     * Returns true if at least one of the listed templates exists

Trace

* None of these templates can be found: Page.ss, ContentController.ss
Line 171 of SSViewer.php
* SSViewer->__construct(Array)
Line 308 of Controller.php
* Controller->getViewer(index)
Line 175 of Controller.php
* Controller->handleAction(HTTPRequest)
Line 107 of RequestHandler.php
* RequestHandler->handleRequest(HTTPRequest)
Line 122 of Controller.php
* Controller->handleRequest(HTTPRequest)
Line 19 of ModelAsController.php
* ModelAsController->handleRequest(HTTPRequest)
Line 262 of Director.php
* Director::handleRequest(HTTPRequest,Session)
Line 106 of Director.php
* Director::direct(/merch/)
Line 115 of main.php

"

i put it in the correct folder and i changed the _config.php file

please help :D

Avatar
Harmonize Media

Community Member, 1 Post

8 March 2009 at 5:14am

I am having this issue as well. I have the latest version of Silverstripe installed and downloaded one of the themes from the .org website.

Avatar
maggieo

Community Member, 2 Posts

8 March 2009 at 8:31am

I've had the same issue, I think its a difference between the new version of SS and the older themes. I even had a problem with the tutorial theme.

I've resolved it by installing black candy when setting up SS and copying the contents of the stylesheets out of the theme I wanted into the blackcandy files.

Hope that helps.

Avatar
lxer

Community Member, 16 Posts

8 April 2009 at 12:23am

same issue here. and i'm using the blackcandy theme ...
Could it be that it doesn't work when it is installed in a subfolder?

Avatar
gaston

Community Member, 24 Posts

8 April 2009 at 1:20am

Salut,
I can create this error message if I use a theme name that is not existing. So I guess, that your issue is related to a typo in the theme selection, upper/lower case mismatch or file protection of the theme folder.

I hope, this helps,
Mathias

Avatar
D@ve

Community Member, 1 Post

29 May 2009 at 4:25pm

It took me some very frustrating hours to found out that templates with underscores or camel case names generally lead to the upper error message...

Works:
- mytemplate

Doesn't work:
- my_template
- MyTemplate
- myTemaplte

best regards
Dave Remmel

Avatar
Willr

Forum Moderator, 5513 Posts

15 June 2009 at 5:38pm

It seems that theme names must be all lowercase and without any other characters.