Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Themes /

Discuss SilverStripe Themes.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[ SOLVED ] - SS3 trying to serve theme that doesnt exist


Reply


3 Posts   280 Views

Avatar
Jimmis

Community Member, 4 Posts

23 July 2014 at 2:46pm

If I add a random 'somethingrandom.php' to any of my SS3 sites. Silverstripe tries to render the 'page not found' template from the 'simple' theme. Even if the theme doesnt exist.

Can someone point me in the right direction here?

Not a big deal, but a problem for when re-building websites that have existing URLs indexed with search engines.

Thanks in advance
J

-------------------------------------------------------------------------------
Your Site Name

Home
About Us
Contact Us
Page not found

Sorry, it seems you were trying to access a page that doesn't exist.

Please check the spelling of the URL you were trying to access and try again.

Your Site Name →
²
Home
About Us
Contact Us
Theme by Sara (Innovatif) / Powered by SilverStripe
--------------------------------------------------------------------------

Avatar
Willr

Forum Moderator, 5513 Posts

26 July 2014 at 11:19pm

Try republishing the error page and 404 page in the CMS. This will publish the HTML for the error page.

Avatar
Jimmis

Community Member, 4 Posts

28 July 2014 at 9:24am

Yeah that worked. Legend!