Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Using User Forms [v0.2.0] on Stable 2.3.4


Go to End
Reply

10 Posts   2696 Views

Avatar
cliersch

10 December 2009 at 1:05pm (Last edited: 10 December 2009 1:06pm), Community Member, 75 Posts

I need some help upgrading from 2.3.3 to 2.3.4 The UserForms Module seems to have a problem. After installing the module with dev/build I'm not able to get into the CMS Section (/admin) .

Undefined index: UserDefinedForm_EmailRecipient

Any solutions?

Avatar
cliersch

11 December 2009 at 12:46am Community Member, 75 Posts

Hm - maybe its a thread for the 'module forum'.
Does anybody use UserForms on Silverstripe 2.3.4?

Avatar
cliersch

11 December 2009 at 12:46am (Last edited: 11 December 2009 12:47am), Community Member, 75 Posts

Avatar
Juanitou

11 December 2009 at 6:10am Community Member, 323 Posts

Hi!

Yes, I’m using it (always extending the page type, but nothing fancy). I don’t remember having problems when updating. Your error is not very descriptive but, in any case, it’s complaining about the name of a required table in the database.

Not very useful, I know…
Juan

Avatar
cliersch

12 December 2009 at 7:14am (Last edited: 12 December 2009 7:15am), Community Member, 75 Posts

There are only the databas tables userdefinedform, userdefinedform_live and userdefinedform_versions
After building the Database I'm not able to get into the CMS.

[Notice] Undefined index: UserDefinedForm_EmailRecipient
GET /silverstripe-v2.3.4/admin?flush=all
Line 157 in C:\xampplite\htdocs\silverstripe-v2.3.4\sapphire\core\ClassInfo.php

and

static function ancestry($class, $onlyWithTables = false) {
152       global $_ALL_CLASSES;
153
154       if(is_object($class)) $class = $class->class;
155       else if(!is_string($class)) user_error("Bad class value " . var_export($class, true) . " passed to ClassInfo::ancestry()", E_USER_WARNING);
156

157       $items = $_ALL_CLASSES['parents'][$class];

158       $items[$class] = $class;
159       if($onlyWithTables) foreach($items as $item) {
160          if(!DataObject::has_own_table($item)) unset($items[$item]);
161       }
162       return $items;
163    }

Avatar
Willr

12 December 2009 at 9:50am Forum Moderator, 5511 Posts

cliersch - tried getting into the cms with a ?flush=1 -> yoursite.com/admin?flush=1

Avatar
danova

8 January 2010 at 4:46am (Last edited: 16 January 2010 8:54am), Community Member, 4 Posts

Your error is not very descriptive but, in any case, it’s complaining about the name of a required table in the database.

Avatar
DaveH

25 April 2010 at 8:05am Community Member, 1 Post

Had a very similar problem when I backed up a live site to a dev machine to test an upgrade to 2.3.7 and to add some additional modules. The upgrade went OK as did adding the extra modules.
The problem arose when I tried to upgrade userforms to v0.2.1 from v0.1.0
The Manifest was not getting updated properly - the cached details about the classes added or changed by the updated version. This appears to be caused by the way the ManifestBuilder determines which cache files are updated when the dev/build is performed.
Since the timestamps on the files unpacked from userforms-v0.2.1.tar.gz were prior to the date of the dev/build which cached the details for userforms-v0.1.0, the cache was not updated correctly. Deleting the cache files from silverstripe-cache/ and re-performing dev/build cured it.
"UserDefinedForm_EmailRecipient" is a new class added by v0.2.0 and can't be found in $_ALL_CLASSES['parents'][$class] because it is not (yet) in the Manifest (cache).

Go to Top