Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Is it possible to downgrade?


Reply


5 Posts   1314 Views

Avatar
animasola

Community Member, 121 Posts

30 January 2010 at 12:32am

Hi, What files would I need to change in order to downgrade to a prior version of SilverStripe? Is it the same as upgrading?

After upgrading to 2.3.4 from 2.3.3, my newsletter module ceases to work. I tried to upgrade to 2.3.5 and it still doesn't work. I would like to downgrade it if possible. Thanks! :)

Avatar
Willr

Forum Moderator, 5513 Posts

30 January 2010 at 5:25pm

There is a reason why new versions have been released and that was to cover a couple security flaws. So downgrading you will expose yourself to that threat of a hacker could get into your site which is not very nice.

I think rather then downgrade the core, fixing the newsletter to work with 2.3.5 is the way you want to go. What do you mean 'it doesn't work' do you get an error? It looks like newsletter hasn't been touched in a couple months so doesn't look like any ones fixed any recent bugs

Avatar
animasola

Community Member, 121 Posts

31 January 2010 at 1:04pm

I get this error:

http://silverstripe.org/all-other-modules/show/276837#post276837

Is there a way to remedy this?

Avatar
animasola

Community Member, 121 Posts

1 February 2010 at 3:02am

Edited: 01/02/2010 3:02am

It seems that the newsletter module doesn't work with 2.3.3 as well. Is there a recent update for this module? Or is there a similar module which does the job?

Avatar
Tim99

Community Member, 10 Posts

1 May 2010 at 12:33am

I upgraded to 2.4-rc, but unfortuately faced [url=http://www.silverstripe.org/general-questions/show/281744#post281744]a serious bug[/url]. Now I wonder, if I can safely downgrade my SS installation until this bug is solved!?