Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

version number in 2.4.6 CMS missing

Go to End

10 Posts   3475 Views


Community Member, 49 Posts

20 October 2011 at 8:22am

after upgrade to 2.4.6 no more display of version number in backend bottom line - shows only "SilverStripe CMS" - but no version number as in all versions before.


Community Member, 43 Posts

21 October 2011 at 12:14pm

Edited: 21/10/2011 12:25pm

Yes, the version number is missing here too. (Upgraded from 2.4.5. to 2.4.6).

Ok, in sapphire/silverstripe_version I only find:


In SS 2.4.5 the line reads:

$URL: $


Community Member, 83 Posts

25 October 2011 at 6:49am

Edited: 25/10/2011 6:59am

does anyone know where to insert the missing version number?
The dashboard module shows that a never version (2.4.5) is available.


i edited 2 files:
Now the dashboard doesnt inform me, that a "never" 2.4.5 is available.

$URL: $

$URL: $


Forum Moderator, 801 Posts

25 October 2011 at 8:54pm

Thats an oversight on our first release from git instead of SVN, where these magic strings are automatically replaced on "svn export". Will be fixed with the next release, sorry about that!


Community Member, 16 Posts

2 February 2012 at 4:00am

Hey Ingo, did I miss something? the new 2.4.7 didn't have it either - is there a safe place I can add it myself? What do you recommend? It's so nice to have the version there...
Thanks in advance.


Forum Moderator, 801 Posts

2 February 2012 at 7:02am

Edited: 02/02/2012 7:03am

Sorry about that. I've now added this to the build file in which ensures that the next release contains this information again.

Also changed the sapphire/cms logic accordingly: - This change is applied to all maintained releases (back to 2.3), as we're no longer building any of those via "svn export".


Community Member, 16 Posts

16 November 2012 at 10:09am

I think the build.xml file is not working still. There is no version for the latest 2.4.8 release (Oct. 31, 2012). Just FYI - the file: silverstripe_version is blank as well (I know the $URL$ substitution used to be there... but now the build is supposed to put it there (I think)).
Thanks - I can update myself, but don't know where?


Community Member, 26 Posts

20 November 2012 at 4:52am

@ChubChub I updated the silverstripe_version file in the /sapphire folder to "2.4.8" and then refreshed the admin panel. The version number is showing up now.

Go to Top