Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SS3 sitetree issue


Reply


5 Posts   1172 Views

Avatar
Guy Van Bael

Community Member, 34 Posts

4 July 2012 at 10:06pm

1. Page is always created at top level, even if another page is selected as partent
2 When a page's location is changed. the cms says 'sitetree rearranged succesfully'. The page is indeed visible at its new position. But if you leave the cms and look at the page, the page is still displayed at the original position. Going into the cms and saving the page again clears the problem.that is ... using multiselectmode and using batch action publish only saves the page in the right place in the sitetree

Anyone else experienced this problem?

I already opened a ticket on open.silverstripe.org (when the latest release was rc3), but in the stable version, the same problem exists

Avatar
Wezzlee

Community Member, 28 Posts

2 August 2012 at 8:26pm

Hi Guy,

Same problem here. I created a Homepage template, when I want to move this Homepage to the top of the sitetree the message appears "sitetree rearranged succesfully' ", but somehow the homepage is still displayed as last menu/sitetree item. Did you already manage to solve this issue?

Wesley

Avatar
Wezzlee

Community Member, 28 Posts

2 August 2012 at 8:29pm

I logged out and logged in again, then I noticed that the Homepage had the status "modified". Saved and published it again and now everything is okay again.

Avatar
tmkp

Community Member, 42 Posts

2 August 2012 at 11:10pm

Edited: 03/08/2012 12:05am

1. Which version are you on? Can't reproduce this but I'm currently still on 3.0 stable

2. This has been an issue for a long time (at least back on 2.x) and should be looked at. It's very counterintuitive and even though i tell my clients on every briefing, they tend to forget that they need to perform a full "save and publish"on every page they want to rearrange.

------------------------

Edit: Just installed 3.0.1 on my machine and everything works as expected. "Save and Publish" is no longer needed on pages after reordering per drag and drop.

Avatar
KTC

Community Member, 1 Post

20 May 2013 at 2:51am

This is apparently still an issue. I have a fresh install of v 3.0.5 on my WAMP localhost and have been following the tutorial to extend the site with the Article and Staff page types. The drag-and-drop to rearrange the tree is rather difficult to control, but once I do get a page in the right place it doesn't affect the site navigation menus until I Save&Publish the moved page. Logging out and in did not do it, nor did ?flush=1.