Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

2.3rc - newsletter admin


Reply


7 Posts   1567 Views

Avatar
Jean-Phi

Community Member, 12 Posts

10 February 2009 at 5:46am

Edited: 10/02/2009 5:53am

Hi,

I'm trying to get newsletter admin module working on 2.3 RC3, but it doesn't.
I've download v0.1 end latest trunk, none of those works.

Does anybody have a solution?

Avatar
mathiasp

Community Member, 12 Posts

13 February 2009 at 4:50am

I also have troubles with newsletter, and I do need it. 2.3 is useless for me without it.

Any help, anyone??

Thx, Mathias

Avatar
Jean-Phi

Community Member, 12 Posts

13 February 2009 at 4:55am

Edited: 13/02/2009 4:55am

I still don't know on to make it work...
Posting on this forum is like looking for water in the desert....

Avatar
Willr

Forum Moderator, 5513 Posts

13 February 2009 at 2:25pm

Try being a bit more descriptive with your request. "It doesnt work" is not very helpful / provide any help for people who could help.

Make sure the site is in Development Mode as this will output all the errors in full. You can set development mode by adding this to your mysite/_config.php file - Director::set_environment_type("dev");

Also check your apache logs for any errors.

Post the errors here or explain what is not working / actions taken to the problem

Avatar
mathiasp

Community Member, 12 Posts

14 February 2009 at 12:24am

Thanks for the tip with dev mode!

Installing newsletter trunk in the dailybuild from 02/12 gives:
Couldn't run query: SELECT "NewsletterType".*, "NewsletterType"."ID", CASE WHEN "NewsletterType"."ClassName" IS NOT NULL THEN "NewsletterType"."ClassName" ELSE 'NewsletterType' END AS "RecordClassName" FROM "NewsletterType" Table 'silver_bengez.NewsletterType' doesn't exist

Line 429 in /usr/www/users/bengez/cms.bengezajaeger/sapphire/core/model/MySQLDatabase.php

and a quick look in the database shows that there are no tables at all with the word "Newsletter" in it...

So, how do I trigger the install for the module. I just copied it into the silverstripe directory after I installed silverstripe.

Now I just reinstalled install.php et al. and tried to re-run it, but it seems that it would overwrite my existing installation.
So, how do I get the needed tables?

Thanks for any pointers, tips, solutions;

Mathias

Avatar
mathiasp

Community Member, 12 Posts

14 February 2009 at 12:29am

OK, re-running install.php did solve my problem, and it left the existing database unchanged.

Cheers, Mathias

Avatar
spark

Community Member, 15 Posts

28 March 2009 at 10:32am

Are you referring to the main install.php file? I tried to reinstall Silverstripe, but my Newsletter tool in the admin is still not functioning.

I can see past newsletters, but when I click on any of the folder in the left nav, nothing happens - and I don't get any errors either.

Any help would be greatly appreciated! This newsletter tool is used by my client every week!

Thanks,
Danielle