Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Upgrade to 2.3.0, TinyMCE button images don't appear


Go to End
Reply

15 Posts   2837 Views

Avatar
david_nash

25 February 2009 at 7:17pm Community Member, 55 Posts

I've upgraded and the TinyMCE button images aren't appearing in the CMS, just the alt text.

It's still referencing the old buttons, eg jsparty/tiny_mce2/themes/advanced/images/bold.gif - which don't exist in the new version.

I think I've done everything I'm supposed to, flushing the db and clearing the cache etc.

Please help!

Avatar
Fuzz10

25 February 2009 at 9:54pm Community Member, 787 Posts

hmm.. are you sure this isn't your browser cache acting up ?

Disable your browser cache or try a different browser just to make sure.

Avatar
david_nash

26 February 2009 at 9:49am Community Member, 55 Posts

Thanks, that was a good idea. I accessed it from my laptop, which I've never used to log in to the CMS before. Still the same problem, no button images.

I have another development site on the same server which upgraded fine, all the button images appear. What else could I try?

Thanks for your help!

Avatar
Fuzz10

26 February 2009 at 11:04am Community Member, 787 Posts

Very odd..

All I can think of is to redo the upload .. maybe something went wrong there ?

Avatar
alirobe

26 February 2009 at 12:54pm Community Member, 35 Posts

I agree with Fuzz10, Try reuploading the upgrade. The new TinyMCE doesn't even have alt text on the buttons (just anchors and spans with css sprites), so you're running the old one there.

FYI: Ctrl+F5 clears the browser cache and reloads everything on the page. You may also want to go to /dev/build/?flush=all or admin/?flush=all to clear out everything on the server (flush=all is new in 2.3).

Avatar
david_nash

26 February 2009 at 4:45pm (Last edited: 26 February 2009 4:45pm), Community Member, 55 Posts

Thanks! I'd already cleared the browser's cache twice and was pretty certain the files were fine, so I tried admin/?flush=all first - and it worked!

Thanks again Fuzz10 and alirobe!

Avatar
Harley

16 June 2009 at 8:27am Community Member, 153 Posts

Hi everyone,

I have had this same problem. First time using Silverstripe, I have to say it is awesome but I am having trouble with this issue.

Here's what has been happening:

1. I installed Silverstripe on my server, worked great but realised I had published it into a folder called Silverstripe so deleted everything to start again.

2. Second attempt at installing it I noticed that the Silverstripe logo didn't fully load in and looked to be corrupted, then when I accessed my pages in the control panel the tiny mce toolbar is corrupt. I have downloaded the latest version and even tried to upload these two images but to no avail.

Now here's is where it gets a bit strange. I have tried some of the suggestions on the forums ie [/dev/build/?flush=all or admin/?flush=all], still no joy. Out of interest I wanted to see what would happen if I completely fresh installed on another domain. The exact same issue has arisen, the images even produce the same corrupt look.

This to me sounds like a browser cache issue, the thing is I get the same thing every time I clear my cache, so I tried to log on in my work place just to make sure I haven't got some crazy caching issue and get the exact same thing.

So could it be my server? Even when I have installed a copy fresh on a completely different site?

Ideas anyone?

Any help much appreciated

Thanks

Avatar
alirobe

16 June 2009 at 3:14pm Community Member, 35 Posts

Hi there. Sounds like you've got a corrupt archive or something of that nature. I'd suggest re-downloading and re-installing SilverStripe.

Go to Top