Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Public vs Private statics in 3.0 -> 3.1 Upgrade


Reply

2 Posts   349 Views

Avatar
novaweb

20 May 2014 at 11:54am Community Member, 115 Posts

Howdy Stripers. I am deploying a 3.0 to 3.1 upgrade. As per docs (3.1.0 changelogs) I have changed static $allowed_actions to private, but now I am getting Fatal error: Page_Controller::$allowed_actions must be public (as in class Page_Controller)

I am confused...

It works on Dev fine, but on production server this error is throwing, same code base, php versions vary but are 5.4+

Any ideas?

Avatar
thomas.paulson

21 May 2014 at 2:56pm Community Member, 79 Posts

Hello there

If your dev code works fine, make sure to update the cms and framework folder with version 3.1 files

Thanks