Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Admin section not working in Firefox after upgrade


Reply

5 Posts   1754 Views

Avatar
jester12345

10 May 2009 at 10:53am Community Member, 8 Posts

I recently upgraded from 2.2.3 to 2.3.1 and I've got a weird problem. The admin section works fine in Safari (on Mac), but not in Firefox (3.0.10, same computer). I've cleared the cache, restarted, flushed the server cache, and even changed the "browser.cache.check_doc_frequency" Firefox setting so it will get a new version every time, and still it's not working.

The issue is when you click a page to edit it, the AJAX fires off and downloads the new editor window, but it never actually loads the content. The "loading" spinner just loads forever. If I reload the page, the page I clicked on loads up (I believe a cookie is dropped). So, it's like it's working... almost. I can use Firebug to look at the result returned from the server and it appears to be there.

Any ideas? A couple of other posts sound similar, but they were related to language settings or updating a file manager. I doubt that's the problem here as it works in one browser but not another.

Thanks in advance!

Avatar
alirobe

10 May 2009 at 10:31pm (Last edited: 10 May 2009 10:31pm), Community Member, 35 Posts

Have you tried loading Firefox in Safe Mode? That will help root out any extensions that might be causing the problem.

Avatar
jester12345

11 May 2009 at 2:30pm Community Member, 8 Posts

Good suggestion!

I just tried it, and am getting the same result.

I dug out my laptop running Linux, and Firefox is doing the same thing. The common denominator seems to be that I updated the Mac and my laptop to run Firefox 3.0.10 recently. I wonder if there is a bug related to that in one of the JS libraries that SilverStripe uses...?

The fact that I upgraded SilverStripe recently could just be a red herring.

Avatar
alirobe

11 May 2009 at 6:11pm (Last edited: 11 May 2009 6:13pm), Community Member, 35 Posts

I've upgraded from 2.2.3 to 2.3.1 and it works fine with Firefox 3.0.10 on my install. Could it be related to some specific configuration you've done? Also, have you tried deleting the contents of the silverstripe-cache folder?

Avatar
jester12345

12 May 2009 at 1:31am Community Member, 8 Posts

We also use SilverStripe at work (although we only just got started, so there was no upgrade involved), and FF 3.0.10 works fine here. So, there must be something wonky with the other setup.

I had not tried deleting the cache files directly as I thought that's what ?flush=all did. I just went in and deleted it manually, and I still get the same result.

Actually, we're having another issue with our web host as well. It's possible this is related. I'll wait until they fix that before worrying about this problem any more.

Thanks for your suggestions!