Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

2.4.7 PHP compatibility


Reply

3 Posts   166 Views

Avatar
redactuk

7 August 2014 at 10:47am Community Member, 117 Posts

Hi folks

I have a very old site still on v2.4.7. I will hopefully be upgrading it in next month or so, but before then, does anyone know of any compatibility issues if PHP version is upgrade from 5.3.X to 5.4.X or even 5.5.X? i.e. can anyone think of anything that may fall over in SS v2 with these newer PHP versions?

Thanks

Avatar
Kirk

7 August 2014 at 11:21am (Last edited: 7 August 2014 11:24am), Community Member, 42 Posts

Don't know of any particular functions (maybe ereg and split) but my advice would be to check the PHP change log

[url]http://php.net/ChangeLog-5.php[/url]

I would also check the deprecated functions as they may be used in the old version of your site or SilverStripe.
See the link below for the deprecated functions between PHP 5.2.*/5.3.* and PHP 5.3.*/5.4.*

[url]http://php.net/manual/en/migration53.deprecated.php[/url]
[url]http://php.net/manual/en/migration54.deprecated.php[/url]

It would be good to grep for the deprecated features in your current source code.

Avatar
redactuk

7 August 2014 at 10:27pm Community Member, 117 Posts

Thanks Kirk.

Server is currently using 5.3 so I'll do some checks for the 5.4 depreciated stuff.