Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

CMS modules missing when upgraded from 2.2.2 to 2.3.1


Reply


2 Posts   911 Views

Avatar
szymon.jankowski

Community Member, 2 Posts

26 May 2009 at 1:27am

Edited: 26/05/2009 1:28am

Hello!

I have recently upgraded my site from 2.2.2 to 2.3.1
Everything was going fairly smoothly until today, when I logged in - for the first time - to the CMS. All of the custom modules that were written using GenericDataAdmin and such did NOT show up in the CMS and all I get is the standard "Site Content", "Files & Images", "Comments", "Security" and "Help" links in the menu.

Were there any changes between 2.2.2 and 2.3.1 that could have affected this behavior? How can I get the new modules to show up in the CMS?

Thanks in advance for any info!

Cheers,

Szymon

Avatar
szymon.jankowski

Community Member, 2 Posts

26 May 2009 at 1:33am

Edited: 26/05/2009 1:34am

Hi!

I just found this info on the http://doc.silverstripe.com/doku.php?id=upgrading:2.3.0 page:

<i>GenericDataAdmin functionality has been moved into its own module called genericdataadmin. If you were previously using this as a feature out of the box with SilverStripe, then you will need to download this module to continue using it.</i>

this seems to be exactly what my problem is, so I'll get at the new module straight away and see if I manage to solve my problems.

Cheers!

Szymon