Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

tinymce.template.js missing from SS v2.3.2


Reply

5 Posts   2660 Views

Avatar
gakenny

28 July 2009 at 4:42pm Community Member, 153 Posts

Hello,

Should this JS library be included in the latest version of SilverStripe? This is required by the Newsletter module and an error is generated when it is missing.

I have copied this from the previous version of SilverStripe as an interim.

Cheers,

Gary

Avatar
Willr

28 July 2009 at 9:12pm Forum Moderator, 5511 Posts

In 2.3.2 we have moved to a PHP based configuration for tinymce settings. See http://doc.silverstripe.com/doku.php?id=htmleditorconfig . Make sure you are using a recent trunk build of the newsletter and make sure you flush=1.

I would have thought newsletter has been updated to use this htmleditorconfig class

Avatar
gakenny

28 July 2009 at 9:50pm Community Member, 153 Posts

Thanks Will - I'll give that a shot.

I was surprised that the latest newsletter module had not been updated!

I'll try the trunk.

Gaz

Avatar
gakenny

29 July 2009 at 7:36pm Community Member, 153 Posts

Hi,

I have tried the trunk and this appears to have resolved the issue.

Thanks a bunch!

Gaz

Avatar
Carbon Crayon

1 August 2009 at 9:22am (Last edited: 1 August 2009 9:24am), Community Member, 598 Posts

Here is a short tutorial on setting up TinyMCE in 2.3.2:

http://www.ssbits.com/customising-the-wysywig-editor-in-v2-3-2-tinymce/

I've also just descovered a pretty major bug in that all inline styles are stripped out and so things like text alignment, italic and underline don't work anymore! I will post a fix soon :)