Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe /

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Upgrade issue


Go to End
Reply


9 Posts   2162 Views

Avatar
Shaunak

Community Member, 7 Posts

11 August 2009 at 6:23pm

I uploaded all the files of 2.3.3 and extracted it over the existing installation (2.3.2)

My site went down !! and I am not able to figure out what is wrong.

I love silver stripe, its the most amazing CMS I have ever seen !!! and now im stranded ... plese HELP !!!!

Avatar
Shaunak

Community Member, 7 Posts

11 August 2009 at 6:24pm

the website is http://taxcode.in

just click on it, to see the error im getting

Avatar
Hamish

Community Member, 712 Posts

11 August 2009 at 6:36pm

looks like a permissions issue. When you extracted it, did you have some special permissions set up that were overwritten?

You don't have permission to access /sapphire/main.php on this server.

That's pretty straight-forward. You need to give your www-data user permission to read your php files.

Avatar
Shaunak

Community Member, 7 Posts

11 August 2009 at 6:49pm

I did not have any special permissions before I upgraded. How do i go about setting these permissions, the file mentioned ie. /sapphire/main.php is not working despite giving that file 777 permission.

Avatar
Hamish

Community Member, 712 Posts

11 August 2009 at 6:57pm

could you post your .htaccess file? I don't think it is directing the request to the right place.

Avatar
Shaunak

Community Member, 7 Posts

11 August 2009 at 7:02pm

### SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<IfModule mod_rewrite.c>
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif$)|(\.jpg$)|(\.png$)|(\.css$)|(\.js$)

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

Avatar
Hamish

Community Member, 712 Posts

11 August 2009 at 7:08pm

Long shot, but could you try adding:

RewriteBase /

after the "RewriteEngine On"

Avatar
Shaunak

Community Member, 7 Posts

11 August 2009 at 9:13pm

There is nothing more,

I pasted the entire file

Go to Top