Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Upgrading SilverStripe

Ask questions about upgrading SilverStripe to the latest version.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

error saving content

Go to End

9 Posts   4663 Views


25 August 2009 at 2:47am Community Member, 49 Posts

I was with issues with silverstripe that i was not able to solve.

I changed the installation and i have done a new instalattion with the last version. I have then copied the sql lines with the content for the new site.
I copied the files as well for the directory of assets.

The site is now showing ok with all the previous content and i am able to see the content in the admin area.

However i get an error saving content when trying to save any page.

How can i detail this error and correct it ?.

Thank you,

Paulo Santos


25 August 2009 at 3:13am Community Member, 49 Posts

when trying to unpublish it also gave an error but the page was unpublished and now i can not publish it again.

Is there any option to go from silverstripe to another tool that works ?
I want to add some content and i am loosing 2 days with no sucess.

I will go back to php :(


27 August 2009 at 4:25pm Community Member, 271 Posts

An error saving content can mean a lot.

What does your server errorlog say?

Do you use Firebug to monitor errors from javascripts?

You should then have more information about where the error is generated.


27 August 2009 at 7:10pm Community Member, 49 Posts

My error log doesn´t say much.

I didn´t try firebug.

I have made a fresh instalation of silverstripe in another domain and compared the existing fields on the tables. After deleting some extra fields like editors and viewers silverstripe started worked normally.

Thank you,

Paulo Santos


19 November 2009 at 9:34am Community Member, 245 Posts

I am seeing this issue a lot on one of my implementations. "Error saving content." But it only happens on the Production server and not on my testing environment or on my local instance. The code in all these places is the same, though. So the only thing I can think of is file/folder permissions?? The login for the web user is a member of the Apache group, and has write access to every folder in the SilverStripe directory.

What else could result in "Error saving content" errors? It happens when you click on Savem on any page in the site.

Thanks for any and all help,


1 December 2009 at 8:09am (Last edited: 1 December 2009 10:24am), Community Member, 16 Posts

This is for version 2.3.4: It happened to me today: "Error saving content". It happened after I added "GoogleSitemap::enable();" to my _config.php. It went away when I deleted that line. Yes, I did a /dev/build/. I have no idea.

EDIT: All good now. My bad! I somehow assumed that doing a /dev/build/ alone would be sufficient when the GoogleSitemap code was in reach. False! One has to "GoogleSitemap::enable();" and *then* rebuild the database. Sorry for the noise ...


1 December 2009 at 8:20am Community Member, 245 Posts

I ultimately determined that this error was due to DATABASE permissions-- specifically, in my case, that the DB user had not been granted DELETE rights. Each time you update a page, a DELETE in teh SiteTree_LinkTracking table is issued a DELETE command. I figured out the details of the error by setting the environment type to "dev" and then using Firebug.



26 January 2011 at 8:30am Community Member, 4 Posts

Realy this problem was solved by rebuilding database.

Go to Top