Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Widgets

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Hamish's Twitter Widget Pack v0.11


Reply

8 Posts   2465 Views

Avatar
SWRL149

3 March 2010 at 6:42pm (Last edited: 3 March 2010 6:52pm), Community Member, 7 Posts

Slick as it is, I'm having an issue with a popup asking to authenticate my twitter username and password before i can proceed. And it wants to authenticate any visitor that come to the site.

I've checked out the .php files for the particular piece of this widget pack but once again my code ability falls short.

is there a work around for this? do i have to go to Twitter and make an adjustment?

Attached Files
Avatar
MjamTaart!

27 November 2010 at 2:55am Community Member, 5 Posts

For anyone who wonders too, as I did the first time I saw the popup:

You just need to fill out the name of the twitter account you want to show. You have to do this in the CMS. After that the pop up won't appear again.

Avatar
biapar

17 February 2011 at 3:23am Forum Moderator, 435 Posts

Do this widget work for SS 2.4.5?

Avatar
MjamTaart!

17 February 2011 at 8:56pm Community Member, 5 Posts

I dont know, got it installed on 2.4.2

Avatar
biapar

18 February 2011 at 4:01am Forum Moderator, 435 Posts

I tried on 2.4.5 and wheh I click on NewTwitterPage, I've error 500.
Work Around?

Avatar
Hamish

18 February 2011 at 8:03am Community Member, 712 Posts

Hi there,

I haven't tested the widgets with 2.4.x (been a long time since I looked at it) but it's a very simple widget and I can't think of anything that would stop it working, unless something has changed in the Widgets API.

Not sure what a TwitterPage is - but if you're getting 500 errors you'll need to look into your Apache log files or turn on dev mode to see what the error was.

BTW I'm just moving the widgets to GitHub and I'll add a feature to handle missing twitter users when I get round to it. See [url]https://github.com/hamishcampbell/silverstripe-twitter-widgets/[/url].

Avatar
biapar

18 February 2011 at 9:19pm Forum Moderator, 435 Posts

My site is already in dev mode but Where I read error?

On gitHub

# Requirements: SilverStripe 2.3.0

Avatar
MjamTaart!

19 February 2011 at 10:45pm Community Member, 5 Posts

Hi Hamish, would you please also notice this post about the Twitter Widget?
http://silverstripe.org/widgets-2/show/14787#post299228