Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Widgets /

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Server error Sorry, there was a problem with handling your request.


Reply


5 Posts   4935 Views

Avatar
growin

Community Member, 41 Posts

25 February 2011 at 4:02pm

I was able to install the blog, picture of the day, blog management, tag cloud, and blog archives. What isn't working is the theme installer, widget installer and Cumulus tag cloud. When installed, the theme is lost and I get Server error. I've used the basic blackcandy theme but the same problem occurs. Any thoughts?

Avatar
Willr

Forum Moderator, 5513 Posts

25 February 2011 at 4:42pm

Try putting the site into devmode. Then errors will be reported to you in the browser. If even after that you cannot see error messages, check your PHP log files. http://doc.silverstripe.org/sapphire/en/topics/debugging#dev-mode

Avatar
growin

Community Member, 41 Posts

25 February 2011 at 6:23pm

Edited: 25/02/2011 6:24pm

Thanks. I should have thought of that. Here's the error when I install Cumulus tag cloud:
[User Error] Uncaught Exception: Object->__call(): the method 'tags' does not exist on 'TagCloudWidget'
GET /blog/

Line 724 in /home/*****/public_html/sapphire/core/Object.php which reads:
724          throw new Exception("Object->__call(): the method '$method' does not exist on '$this->class'", 2175);

I installed widgets & modules in the same folder as cms, assets, mysite, etc folders (primary) and ran dev/build. The widgets & modules only show in the blog page in admin.

I removed the Cumulus widget and the blog page now shows:
[User Notice] RestfulService::connect is deprecated; use RestfulService::request
GET /blog/

Line 100 in /home/*****/public_html/sapphire/api/RestfulService.php

I removed the "Picture of the day" widget and it works again. What am I doing wrong?

Avatar
Willr

Forum Moderator, 5513 Posts

25 February 2011 at 7:44pm

I removed the "Picture of the day" widget and it works again. What am I doing wrong?

You're not doing anything wrong but it looks like from those errors that the widgets don't support SS 2.4. You could download the older 2.3 release and use that with the widgets however it would be better to update the widgets to support 2.4. If you have any development experience you can tackle this yourself (a upgrading 2.3->2.4 is available http://doc.silverstripe.org/sapphire/en/changelogs/2.4.0). Otherwise you may want to bug the author of the widget to upgrade.

Avatar
growin

Community Member, 41 Posts

25 February 2011 at 9:15pm

While we're talking about this, having the star feedback and comments on the widgets, themes, modules, etc in Extensions would be a great idea so that, in this case, a note can be left ie. "no longer supported" or "doesn't work with 2.4". I don't have the experience or knowledge to upgrade these.