Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Widgets

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing widgets, block BlogHolder pages from being able to load in CMS


Go to End
Reply

12 Posts   1676 Views

Avatar
DsX

19 March 2013 at 12:19pm Community Member, 178 Posts

Installing widgets, block BlogHolder pages from being able to load in CMS.
and a error popp shows for a few seconds:
=====
Warning at line 670 of F:\vhost\mysite\httpdocs\framework\view\SSViewer.php
=====

removing 'widgets' and rebuilding fixes this; however, I need to add widgets to my blog templates

help??

Avatar
katja

1 May 2013 at 2:20pm Community Member, 46 Posts

Hope you managed to fix it in the meantime..

Anyway, I had the same problem, and strangely got it working by just emptying the silvestripe cache. The error messages were about not finding the WidgetArea template, but I could see in the code that it did actually exist, and in fact nothing seems to have been wrong with the installation.

Avatar
ecadre

14 June 2013 at 1:48pm Community Member, 5 Posts

I seem to be having the same problem as the OP.

After installing the Widgets module, the Blog holder page is now blank on the admin.

I've tried /?flush=1 but to no avail.

This is on the admin side, the page on the frontend (public) loads OK.

Avatar
katja

14 June 2013 at 9:21pm Community Member, 46 Posts

There should be a Silverstripe cache directory under the tmp directory of your system. That's the one I cleared..

Avatar
ecadre

15 June 2013 at 12:15am Community Member, 5 Posts

Thanks for replying and the suggestion but, sadly, that too made no difference.

I'm getting this on my desktop box and the server install as well, both Debian.

Avatar
ecadre

15 June 2013 at 12:56am (Last edited: 15 June 2013 12:56am), Community Member, 5 Posts

OK, I've turned on development mode on my desktop install and it's coming up with this error:

Error at line 1334 of /home/ecadre/myfiles/sites/silver-stripe/framework/model/DataObject.php

The line reads:

throw new Exception("DataObject->getComponent(): Could not find component '$componentName'.");

So, summat's missing, but what?

Avatar
katja

15 June 2013 at 1:36am (Last edited: 15 June 2013 1:37am), Community Member, 46 Posts

Sorry to hear it didn't help. I remember fiddling around with all this for ages. I think one of the problems was finding the right versions of modules to go together. This is not really documented anywhere.. Have you used composer to install them? I think it was in the end the only way for me to get versions that worked together.

Perhaps this helps:

composer.json
{
   "name": "silverstripe/installer",
   "description": "The SilverStripe Framework Installer",
   "require": {
      "php": ">=5.3.2",
      "silverstripe/cms": "3.0.*@stable",
      "silverstripe/framework": "3.0.*@stable",
      "silverstripe-themes/simple": "*",
      "silverstripe/blog": "0.6.1",
"silverstripe/widgets": "0.1.*"
   },
   "require-dev": {
      "silverstripe/docsviewer": "*",
      "silverstripe/behat-extension": "*",
      "silverstripe/buildtools": "*",
      "phpunit/phpunit": "3.7.*"
   },
   "minimum-stability": "dev"
}

Avatar
ecadre

15 June 2013 at 2:41am Community Member, 5 Posts

Yes, I tried composer earlier today, but it did not work. The only version of the Widgets module it has is the one compatible with SilverStripe 3.1 (a beta release) so of course it refused to install on 3.0.5.

Is it permissible to roll my eyes at this point? :-D :-/

The versions of the Blog module and the Widgets module are the same as yours (thanks for that) and I'm still on the default "Simple" theme since I am still trying things out.

I don't mind "fiddling around" with stuff, but I am a little frustrated here with what seems a standard install of SilverStripe.

I know it's not your responsibility of course katja, thanks for taking the time to reply to me with some useful info, I'll have another dig around inside SilverStripe later to try to see what's going on.

Go to Top