Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Widgets

Discuss SilverStripe Widgets.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

IE 6 Detection widget


Reply

5 Posts   3348 Views

Avatar
simon_w

23 February 2009 at 5:18pm Forum Moderator, 474 Posts

I have released a widget that detects if a user is running IE 6 or earlier, and displays a customisable message warning them that the site may not display properly and that they should upgrade.

It also has an optional JavaScript alert box that can display along with the widget.

Download from [url=http://silverstripe.org/widgets/]here[/url].

Avatar
Carbon Crayon

25 February 2009 at 4:52am Community Member, 598 Posts

Surely you should just be making sure that your site does display properly in IE6 ;)

I guess you could use it to say "I just want you to know that I went through hell to make this site work for you and your ancient browser. I and every other web developer would really appreciate it if you made the effort to update your viewing platform at intervals shorter than 9 years. Thanks"

Jokes aside though, with up to 40% of web users still using IE6 (and many of them not out of choice) it seems a little premature to start taking a stand. And if any site ever pops up an alert that is not absolutely essential I would usually just leave. That might be just me though :)

Avatar
Nivanka

25 February 2009 at 7:31pm Community Member, 395 Posts

a little addition Aram, just make the popup a select box, and add a button called "Update now" on which when someone clicks he / she will be pointed out to the IE 7 downloading page ;)

Avatar
Hamish

25 February 2009 at 8:14pm Community Member, 712 Posts

..or the FF3 download page :)

A resource for web developers:

[url]http://canistopsupportingie6yet.com/[/url]

Avatar
grilldan

25 February 2009 at 8:51pm Community Member, 135 Posts

I miss my buddies at savethedevelopers.org.