Jump to:

382 Posts in 210 Topics by 196 members

Connect With Other SilverStripe Members

SilverStripe Forums » Connect With Other SilverStripe Members » Pages are not getting saved

For all SilverStripe-related topics that don't fit into any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 839 Views
  • anujkryadav
    Avatar
    Community Member
    30 Posts

    Pages are not getting saved Link to this post

    Hello
    I have created a website in silverstripe in my system (localhost) and have installed the website in live server,its working fine except when I try to make any changes from admin panel and try to save the file its giving me saving error.I am not been able to make any changes using admin panel,I am using admin login ,I have not created any other user.IN my system (localhost) saving is working fine.
    I have given the folder every rights that is read,write execute ececute. to all the folder in my site.

  • CodeGuerrilla
    Avatar
    Community Member
    105 Posts

    Re: Pages are not getting saved Link to this post

    You should only make the assets/ folder writable by the webserver user otherwise you are opening a large security hole.

    Is it just uploading of files or saving in general? We had a similar problem with a live website ended up we were using a read only database user and not the db admin user so check your details there.

    You can also set your SS enviroment to dev to see if there are any errors.

    Director::set_environment_type('dev');

    If you have CPanel on your hosting you can also check the httpd error logs for some clues, otherwise contact your hosting provider and ask them for help

    839 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.