Jump to:

513 Posts in 209 Topics by 259 members

Content Editor Discussions

SilverStripe Forums » Content Editor Discussions » TinyMCE editor striping code in SS 2.3.7

Forum for content editors and CMS users.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 927 Views
  • Chip Designs
    Avatar
    Community Member
    15 Posts

    TinyMCE editor striping code in SS 2.3.7 Link to this post

    I have currently upgraded my SS from 2.3.3 to 2.3.7. My TinyMCE editor is striping code from the html - it did however use to work by modifying the cms/code/LeftAndMain.php in SS 2.3.3 as i have done so below.

    Example code:
    <script type="text/javascript" src="http://www.weatherzone.com.au/woys/graphic_current.jsp?postcode=POSTCODE"></script>
    <br /><a href="http://www.weatherzone.com.au/radar.jsp">weather radar</a>

    I have changed the cms/_config.php file by changing:

    'valid_elements' => "+a[id|...etc
    to
    'valid_elements' => "*",

    Now when i add the code, the editor is leaving the <script> tags behind but is striping the 'type' and 'src' from the <script> tag rendering it useless. I think I am on the right track and have read many, many threads on this matter, but there are not many for versions of SS 2.3+. I have looked at the cms/javascript/LeftAndMain.js file but can't see anything that should be causing issues.

    Any ideas?

    Cheers,
    Rob

  • Chip Designs
    Avatar
    Community Member
    15 Posts
    927 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.