Jump to:

520 Posts in 248 Topics by 263 members

Content Editor Discussions

SilverStripe Forums » Content Editor Discussions » CMS shows changed pages, but they were not touched

Forum for content editors and CMS users.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1745 Views
  • WalterW
    Avatar
    Community Member
    18 Posts

    CMS shows changed pages, but they were not touched Link to this post

    Nearly every day, when I look in our CMS, there are some pages marked green. If I go to page history (and also select unpublished versions) and do a compare of the newest unpublished v ersion with the last published version, there is no difference marked.

    So I publish these unpublished versions (which are identical since long time), the green marking goes away, until some next day in the near future.

    Has anyone some idea, what to check for this behaviour?

    Walter

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: CMS shows changed pages, but they were not touched Link to this post

    Yeah, I noticed this before as well..

    I haven't got a clue on how to fix it though.... ;-)

  • socks
    Avatar
    Community Member
    190 Posts

    Re: CMS shows changed pages, but they were not touched Link to this post

    This is happening to me too. Only on my HomePage.

    If anyone wants to compare to see what maybe triggering this, here's my file.

    Attached Files
  • socks
    Avatar
    Community Member
    190 Posts

    Re: CMS shows changed pages, but they were not touched Link to this post

    I think my Home page status went to "changed" after messing with my DataObjectManager PHP pages. Not sure how those would trigger the issue on the seemingly unrelated Home page.

  • figjam
    Avatar
    Community Member
    10 Posts

    Re: CMS shows changed pages, but they were not touched Link to this post

    I have the same problem - but it's worse than Walter describes...

    Try this - republish all pages that have mysteriously become green links in the site tree. Then refresh your browser (or use a different browser) and OOPS! - they (or a slightly different set) are back to being green!

    After trying many things over the last month, here's what I've noticed about repeatedly republishing green links.

    • Out of 120 pages in my site, mostly the same 10-20 pages need republishing (but not always the same set)
    • Recreating pages (via a new page and copying content) didn't help
    • The pageId doesn't seem to be a factor
    • The pages that need republishing generally have many links and pictures in them

    This is all rather frustrating to my content editor (who keeps republishing unchanged pages) and is resulting in page histories filling up with unchanged versions...

    Any clues or suggestions gratefully received!

    Thanks...Fig

  • Hello_electro
    Avatar
    Community Member
    80 Posts

    Re: CMS shows changed pages, but they were not touched Link to this post

    Has anyone else noticed this problem? I have a site with version 2.3.5 and certain pages keep going back to green.

    1745 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.