Jump to:

5514 Posts in 1733 Topics by 1219 members

Customising the CMS

SilverStripe Forums » Customising the CMS » Error message after login

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1371 Views
  • bartvanirsel
    Avatar
    Community Member
    94 Posts

    Error message after login Link to this post

    I am trying to figure out something simple which doesnt seem simple. Maybe its also caused by being in code to long now

    When logging in and not filling out anything or filling out wrong credentials i cant get an error message to appear. This is also not the facts when trying to login on this forum. How do i get an error message above the login form when logging in failed?

  • Aram
    Avatar
    Community Member
    598 Posts

    Re: Error message after login Link to this post

    Hi Bart,

    Did you figure this out? I am having the same problem when using a Custom Login form template....

    Cheers,

    Aram

    www.SSbits.com - Your one stop SilverStripe learning resource.

  • Aram
    Avatar
    Community Member
    598 Posts

    Re: Error message after login Link to this post

    Ok I found the problem,

    When using a custom template (i.e. Security_login.ss) you need to use $Form rather than $LoginForm.

    Hope that helps

    Aram

    www.SSbits.com - Your one stop SilverStripe learning resource.

  • leafchild
    Avatar
    Community Member
    41 Posts

    Re: Error message after login Link to this post

    Hi Aram,

    I think I have an same issue and I couldn't understand the solution you put above.

    I thought form is not working at all but after I read this thread I enter all the value and submit then it's working...

    If I don't enter anything then look like the page is just refreshing,,,,

    I created "MyForm.ss" , "MyForm.php "then

    in Contact.ss

    $MyForm

    thanks,

  • martimiz
    Avatar
    Forum Moderator
    1067 Posts

    Re: Error message after login Link to this post

    Just wondering - I can't really think of a user that doesn't enter anything at all and then doesn't understand that he can't login without explanation. I could maybe think of a bot that pushes a button - and that I don't want to provide with unneeded info.

    So I would be quite happy if this were by design. Please tell me if and why this doesn't make sense...

  • JonoM
    Avatar
    Community Member
    103 Posts

    Re: Error message after login Link to this post

    *Bump*

    I've found this to be a problem too. Going to the default login URL i.e. mysite.com/Security/login and entering wrong credentials the page just appears to refresh. No error message. Does anyone know how to correct this? Ideally there should be a message like "Invalid username or password". The same is true of this forum - if you try to login with bogus credentials the login page appears to just refresh.

    Thanks

    1371 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.