Jump to:

5541 Posts in 1738 Topics by 1224 members

Customising the CMS

SilverStripe Forums » Customising the CMS » Cannot create folders in Assets (sudden problem)

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1306 Views
  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Cannot create folders in Assets (sudden problem) Link to this post

    All of a sudden , it is impossible to create new directories within the Assets dir by using "files and images" ....

    The file / directory rights are okay (the apache user has full read/write rights) , and it _is_ possible to add files or rename already existing directories. I can also delete existing dirs.

    Silverstripe does not produce an error; it just kinda' hangs (ajax process never stops)....

    This is a big problem for us, since it impairs my clients work bigtime...

    Anyone experienced this before ?

  • ajshort
    Avatar
    Community Member
    244 Posts

    Re: Cannot create folders in Assets (sudden problem) Link to this post

    It sounds like this may be a similar problem as the one at http://open.silverstripe.com/changeset/68223 - do you want to try manually chucking that patch in, and see if that fixes the issue?

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Cannot create folders in Assets (sudden problem) Link to this post

    Thanks for the tip !!!! ...

    I'm trying this as we speak.... Have to wait for an (automated) upload to happen to the production server to see what it does. Will let you know ASAP.

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Cannot create folders in Assets (sudden problem) Link to this post

    Thanks again !!!!

    Solved my problem with that patch ! Weird though , that only happens on some servers (in this case, on our load-balanced server with shared dirs)...

  • Taffy
    Avatar
    Community Member
    119 Posts

    Re: Cannot create folders in Assets (sudden problem) Link to this post

    Hi Fuzz10,

    I see you have a staging > production environment with an automated update/deployment of files and databases. I was wondering whether you can give me a summary of your setup (e.g cron job etc)?

    Thanks

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Cannot create folders in Assets (sudden problem) Link to this post

    Hi Taffy,

    Sorry to disappoint you ... ;-) It's nothing more than a Subversion roll-out ... Which happens (semi-)automatically together with a whole bunch of Java backend stuff ...

  • Taffy
    Avatar
    Community Member
    119 Posts

    Re: Cannot create folders in Assets (sudden problem) Link to this post

    Ah right, cheers Fuzz10.

    Would be interesting to know if anyone has developed any functionallity that deploys database and file changes from a staging to a production server.

    1306 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.