Jump to:

5513 Posts in 1732 Topics by 1218 members

Customising the CMS

SilverStripe Forums » Customising the CMS » Selective translation in CMS.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 973 Views
  • le_banana
    Avatar
    Community Member
    21 Posts

    Selective translation in CMS. Link to this post

    Hello Everybody

    I have a liitle problem with translations in SS cms. I'm actually using 2.3 version of Silverstripe. I've changed default english language in admin's profile , for my national - polish , and right now result are a little bit strange. Translation are selective for example:

    In Site Content menu, under main tab, right now I have buttons like:

    Nieopublikowane | Delete from the draft site | Save | Zapisz i opublikuj.

    As you see, translations looks like: polish, english, english, polish.

    I've checked lang file (cms/lang/pl_PL.php) and i can see translations, that i'm missing in cms. (For example: $lang['pl_PL']['CMSMain']['DELETE'] )
    Do you know, how can i fix it?

  • Ingo
    Avatar
    Forum Moderator
    801 Posts

    Re: Selective translation in CMS. Link to this post

    Hey there, I've created a ticket for this: http://open.silverstripe.com/ticket/3930 - can't check currently, as we're having trouble with the member profile editor in 2.3...

  • le_banana
    Avatar
    Community Member
    21 Posts

    Re: Selective translation in CMS. Link to this post

    I've downloaded the newest version of SS and I see, this issue was solved.

    Translations now are ok, and I don't need to change it manually

    Thanks!

    973 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.