Jump to:

5453 Posts in 1674 Topics by 1198 members

Customising the CMS

SilverStripe Forums » Customising the CMS » Problem creating new pages using IE6

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 880 Views
  • AlexR
    Avatar
    Community Member
    3 Posts

    Problem creating new pages using IE6 Link to this post

    For some reason, IE6 just hangs when you press the 'Create' button from the Site Content and Structure menu on one instance of silverstripe. Neither the drop down menu or the go button are shown. This functionality seems to work in all other browsers. I have even seen this work in a different instance of silverstripe using the same IE6 browser.

    Has anyone got any ideas as to why this would stop working?

    A little background:
    I have created 3 additional page types: Home page, Service page and a Service Search page.
    I have amended the default page type.
    I have added the HTMLContntWidget and made it available on all pages.
    I have also had to edit the tinymce javascript files to enable the HTMLContent widget to be removed.

    I'll post the changes I've made if anyone thinks that will help.

    Thanks in advance
    Alex

  • baba-papa
    Avatar
    Community Member
    279 Posts

    Re: Problem creating new pages using IE6 Link to this post

    Just don´t use IE and the problem is gone for shure. IE´s are every programmers doom. If people wouldn´t use IE, our work would be much more fun.

  • banal
    Avatar
    Community Member
    901 Posts

    Re: Problem creating new pages using IE6 Link to this post

    Internet Explorer is here to stay. But people should really start to say goodbye to IE 6. This browser is now about eight years old. Honestly, what other programs from that time are you using?

    I'm not saying a website shouldn't work in a lot of browsers, Mostly I still do compatibility tests with IE 6 and even pay attention that a website degrades nicely in older browsers (as all web-developers should). But for a CMS, which is only used by a limited amount of users, I think one could convince the users to use another browser.

  • COGO
    Avatar
    Community Member
    4 Posts

    Re: Problem creating new pages using IE6 Link to this post

    I agree. No pointing in making a CMS work in IE6. It's dead and gone (nearly). You may as well expect it work in Netscape!

    880 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.