Jump to:

3461 Posts in 1065 Topics by 740 members

Data Model Questions

SilverStripe Forums » Data Model Questions » Symbolic links on installation

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 426 Views
  • esakrielaart
    Avatar
    Community Member
    56 Posts

    Symbolic links on installation Link to this post

    Hi all,

    after reading some topics from around 2009, I'm still struggling to get silverstripe installed using symbolic links to allow multiple sites to use the same codebase. The base site is working, but any modules I add on a per site basis are ignored by dev/build. I think this has to do with the fact that the BASE_PATH generated by framework/core/Core.php equals the path to my framework/cms location, not the path where the site-specific files are located and from where the symbolic links call to framework and cms folders.

    Is there any clarity on this subject by now, or is it unfortunately still not possible to have this kind of set up? I manage my own server, so any advanced settings are possible to execute (Ubuntu server edition).

    Regards,
    Maurice

  • DesignerX.com.au
    Avatar
    Community Member
    107 Posts

    Re: Symbolic links on installation Link to this post

    Hi:
    Good question , I also have a VPS & it could save me alot of time getting Symbolic Links to work with SS on my Centos VPS . I did a basic test & it faild so I did not look any further but still love to see a solution ;)

    426 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.