Jump to:

3462 Posts in 1065 Topics by 740 members

Data Model Questions

SilverStripe Forums » Data Model Questions » Just a blank page

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1372 Views
  • saimo
    Avatar
    Community Member
    67 Posts

    Just a blank page Link to this post

    So, first: This is my first post since the forums remake, and I couldn't find a suitable category for this, so admins: feel free to move it somewhere else.

    My problem started earlier this week when one of the content editors where editing a page. According to him, the cms stopped responding, which made him restart the browser and when trying to visit the site again it wouldn't work.

    Basically, the server won't send any data at all (according to wget). However, bd/build works as usual. I've also tried some various combinations of urlvariables (http://doc.silverstripe.com/doku.php?id=urlvariabletools) and I find them to work very strangely. Basically I need to use showqueries or showtemplate to get any output at all (setting them to 0 or 1 makes no difference). If I also set debug=1 I get some more debug output but if I remove showqueries or showtemplate all the output disappears.

    Basically, I'm at a loss, just because this error seems to be completely silent, so far I haven't gotten a single error message. Anyways, this is using silverstripe-2.2.3 and the gallery module and I currently don't have the time to investigate a move to ss-2.3. I really need to solve this soon, as the site has been down for a couple of days already. So, how should I proceede to debug this issue?

  • saimo
    Avatar
    Community Member
    67 Posts

    Re: Just a blank page Link to this post

    Ok, so I've narrowed it down to an inconsistent db. Restoring a (rather old) backup of the database solves the problem, but is not really a solution since the backup is really too old. So this thread is now about: how to search the database for inconsistencies?

  • steve_nyhof
    Avatar
    Community Member
    224 Posts

    Re: Just a blank page Link to this post

    fixed

    1372 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.