Jump to:

7940 Posts in 1543 Topics by 946 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » [Solved] Help! Can't access Files and Assets anymore!

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 1947 Views
  • Shauna G
    Avatar
    Community Member
    52 Posts

    [Solved] Help! Can't access Files and Assets anymore! Link to this post

    I've been playing with ImageGallery for the past couple of days, trying to get it working how I need it. Well, I solved the other problems that were keeping me from moving forward, but now I've run into a pretty major snag: I get the white screen of death when trying to access "Files and Assets" in the CMS. This only happened after creating a couple new ImageGallery pages and uploading ~50 images total to them. This was even after I had gotten it working again after re-creating the first two pages I made (which had broken it because of duplicate folders). It's also only the "Assets and Files" page of the CMS that isn't working. I can access the other CMS pages, and I can access the live versions of the pages I've created, complete with images and gallery.

    Does anyone happen to know what's going on and how to fix it?

    **Edit: I figured out the problem. I had enough assets to run out of allotted memory, it just wasn't obvious because I didn't get the "out of memory" errors (or any errors, for that matter, regardless of what error handling I tried to implement) that I had seen other people with this problem get.

  • UncleCheese
    Avatar
    4085 Posts

    Re: [Solved] Help! Can't access Files and Assets anymore! Link to this post

    Can't really help you if you don't have error reporting turned on. Get a readable error and see what's up.

  • Chris Rae
    Avatar
    Community Member
    17 Posts

    Re: [Solved] Help! Can't access Files and Assets anymore! Link to this post

    Further to UncleCheese's reply

    http://doc.silverstripe.org/doku.php?id=error-handling

    Hopefully that information is still reasonably accurate.

  • Shauna G
    Avatar
    Community Member
    52 Posts

    Re: [Solved] Help! Can't access Files and Assets anymore! Link to this post

    That's the thing, though, I'm not getting any errors. I have the site in dev mode already (unless there's a separate one for the CMS versus the front end), and I've tried writing the errors to a log and emailing errors and warnings and I'm not getting anything. Even Web Developer and Firebug return nothing (as far as they're concerned, it's an empty html doc).

    Here's ?debug=1 and ?debug_request=1 though. It's the best that I know of that gives any output at all.

  • George
    Avatar
    Community Member
    41 Posts

    Re: [Solved] Help! Can't access Files and Assets anymore! Link to this post

    Hi,

    maybe PHP safe mode is on?

  • Shauna G
    Avatar
    Community Member
    52 Posts

    Re: [Solved] Help! Can't access Files and Assets anymore! Link to this post

    There doesn't appear to be anything to indicate that. The WSoD on any page has been, in the past, triggered by something I did Silverstripe doesn't like. This time, however, if it's something it doesn't like, it's not something I've done directly, as the only thing I've done is upload images in a way that it would take. The only thing I can think of is the number of images that have been uploaded, but that doesn't really make much sense, as the front ends of the galleries I've created work, as well as the rest of the CMS.

  • Shauna G
    Avatar
    Community Member
    52 Posts

    Re: [Solved] Help! Can't access Files and Assets anymore! Link to this post

    Okay, it seems I've figured it out. From the looks of it, the number of assets I have exhausted the memory limit. I had to add:

    ini_set('memory_limit', '128M');

    to get it to show up. Unfortunately, I don't know how much it needs right now, so I don't know how much more I have left. Is there a way to manually check that?

  • UncleCheese
    Avatar
    4085 Posts

    Re: [Solved] Help! Can't access Files and Assets anymore! Link to this post

    Silverstripe doesn't necessarily throw all PHP errors. It's not enough to have your site in dev mode. You need to have error reporting turned on in your PHP configuration.

    php_value display_errors On

    1947 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.