Jump to:

7940 Posts in 1543 Topics by 946 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » 2.3 Branch

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3
Go to End
Author Topic: 5756 Views
  • Juanitou
    Avatar
    Community Member
    323 Posts

    Re: 2.3 Branch Link to this post

    Hi!

    I fear the latest security release of the SS 2.3 branch (2.3.9) has broken something related to DOM, since I’m getting the "Undefined index: start" in line 135 of DataObjectManager.php seen elsewhere when trying to edit files in Asset Manager, and a ImageDataObjectManager that has stopped working without errors (verified with my limited knowledge of the Firebug console): when I try to add a next image previously uploaded, I can select the folder, the Ajax icon turns a little, then nothing.

    Has the 2.3 branch of DOM been updated to work with SS 2.3.9?

    Best regards,
    Juan

  • UncleCheese
    Avatar
    4085 Posts

    Re: 2.3 Branch Link to this post

    Yes, you can check it out from

    ---------------
    Silverstripe tips, tutorials, screencasts, and more. http://www.leftandmain.com

  • Juanitou
    Avatar
    Community Member
    323 Posts

    Re: 2.3 Branch Link to this post

    Thank you very much.

    The latest changes (rev. 522) have restored the edition feature in the Assets Files & Images section, there’s no more “Undefined index: start”. Nevertheless, an error persist when using Next, Previous and Save links in the pop-up window:

    tabstrip.js

    $("Form_EditForm").getElementsByTagName is not a function
    var divs = $('Form_EditForm').getElementsByTagName('div');

    After closing the pop-up, the layout of the asset manager is broken, a lot of divs are missing, no list of files, nor folders, etc. That’s a JS conflict, isn’t it ?

    On the other hand, the ImageDataObjectManager associated with all my pages is still not working. I’m attaching a snapshot of the result when selecting a folder plenty of images. Before, I had check-boxes and thumbnails of every image in the folder, now, after selecting the folder, Ajax only returns the list of images (if any) already associated with the page. No errors.

    Hope it helps,
    Juan (who, by the way, knows how to associate Images by directly modifying the database – whew!)

    5756 Views
Page: 1 2 3
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.