Jump to:

7939 Posts in 1472 Topics by 944 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » SS2.4 can't install DOM

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2449 Views
  • Lukef
    Avatar
    Community Member
    32 Posts

    SS2.4 can't install DOM Link to this post

    When I upload the DOM folder and run /dev/build the only change that is listed is;

    Field File.ClassName: changed to enum('File','FLV','MP3','Image','Folder','Image_Cached') character set utf8 collate utf8_general_ci default 'File' (from enum('File','Image','Folder','Image_Cached') character set utf8 collate utf8_general_ci default 'File')

    If I recall correctly it should have more than that, shouldn't it?

    Then when I try to login to the CMS I see this error...

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 232 bytes) in /home/austrack/public_html/sapphire/forms/EmailField.php on line 56

    Normally that tells me I simply need to push the php memory limit up, which I did but it makes no difference. I have other near identical sites running on 64m but I still get the same error even with the php memory limit set to 256meg, so I am assuming that is not the problem...

    Can you guys help me out?

  • Lukef
    Avatar
    Community Member
    32 Posts

    Re: SS2.4 can't install DOM Link to this post

    um... anyone have any ideas?

  • Lukef
    Avatar
    Community Member
    32 Posts

    Re: SS2.4 can't install DOM Link to this post

    if i have not provided the right info please let me know, or if i have broken some unwritten rule i do apologize but I am getting tired of this issue hanging over my head... i really want to get it sorted can someone give me a hand...

  • UncleCheese
    Avatar
    4085 Posts

    Re: SS2.4 can't install DOM Link to this post

    I run all my SS sites on 256M. 32M sounds awfully low. I would just keep increasing it until you get it to run. There's a memory intensive process in there somewhere that has to be resolved. The most common place we see memory leaks in SS is when many images are being resampled. The GD library is a real hog.

    It might be one specific page in the admin that's giving you trouble. Keep in mind it defaults to the last page edited, stored in your session. So you can try forcing different pages by going to /admin/show/ID, where ID is a SiteTreeID to edit.

  • Lukef
    Avatar
    Community Member
    32 Posts

    Re: SS2.4 can't install DOM Link to this post

    THANK YOU UNCLE CHEESE!

    Well i did briefly try 256M and it did not seem to make a difference, but to give it the benefit of the doubt i will try it again this afternoon, as soon as i get back to my desk.

    will post back then.

    |G|

  • Lukef
    Avatar
    Community Member
    32 Posts

    Re: SS2.4 can't install DOM Link to this post

    Ok i tried pushing up the memory limit all the way to 1024M, but that changed nothing, then i tried forcing it to select another admin page, this did not help either... is there anything else it could be?

  • Phalkunz
    Avatar
    69 Posts

    Re: SS2.4 can't install DOM Link to this post

    Hi Glitch,

    It's working fine for me except DOM style and interaction (javascript) do not work but that is another story. I'm using SilverStripe versions 2.3 and 2.4 and with default memory limit.

    Could you please provide more like what versions of SilverStripe and the module you're using? What are other modules you're using? And also what database platform is your site on? This will help me or others to find the problem. Furthermore, if you have a code written to hook up with DOM module, also post it here.

    You can also try the module with a clean SilverStripe installation.

    Cheers,
    Phalkunz

  • Lukef
    Avatar
    Community Member
    32 Posts

    Re: SS2.4 can't install DOM Link to this post

    Ok here are the extra details

    1: Had working site on SS2.3 (including image_gallery/DOM/swfupload and User Defined Forms)
    2: Moved site to another host
    3: Upgraded to SS2.4 still using User Defined Forms but whenever i try to add DOM i get the memory errors. (have tried trunk and stable, same results)

    Ps: The DB is mySQL

    Many thanks for having a look Phalkunz

    |G|

    2449 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.