Jump to:

7935 Posts in 1536 Topics by 943 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » ImageGalleryPage - Error Saving Content

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5 6 7
Go to End
Author Topic: 9018 Views
  • raZbi
    Avatar
    Community Member
    11 Posts

    ImageGalleryPage - Error Saving Content Link to this post

    Having an issue with ImageGallery module - when clicking Create ImageGalleryPage, nothing just happends. If i refresh page, Unpublished and unsaved "NewImageGalleryPage" appears, but i can't save it - receiving "Error Saving Content" message.

    I'm stuck, trying to figure out, how it happens. Just installed SS 2.4.2., DOM Uploadufy and Image Gallery modules, plus Blog module. Sometimes this bug appears, sometimes not. Any idea, what should i check first?

  • UncleCheese
    Avatar
    4085 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    What is the error, exactly? Check the response..

    --------------------
    SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com

  • raZbi
    Avatar
    Community Member
    11 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    Here's what in logs:

    [27-Sep-2010 05:35:38] Warning at sapphire/filesystem/File.php line 408: rename(/var/www/242.mcm.lv/assets/image-gallery/New-ImageGalleryPage-7/Default-Album/,/var/www/242.mcm.lv/assets/image-gallery/New-ImageGalleryPage-2/Default-Album/) [<a href='function.rename'>function.rename</a>]: No such file or directory (http://242.mcm.lv/admin/EditForm)
    [27-Sep-2010 05:35:38] Error at sapphire/filesystem/File.php line 409: Uncaught Exception: Cannot move /var/www/242.mcm.lv/assets/image-gallery/New-ImageGalleryPage-7/Default-Album/ to /var/www/242.mcm.lv/assets/image-gallery/New-ImageGalleryPage-2/Default-Album/ (http://242.mcm.lv/admin/EditForm)

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    UPDATE
    so, both of my tests were done on subdomains, just tested a new install on a TLD and it works.
    could this be an issue with subdomain permissions UC?

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    nope, ignore that.
    just tested on another domain, as a subdomain, with 2.4.2 and it worked!
    confused now....

    so far it only seems to fail on my clickheredigital.co.uk domain. (subdomains of it)

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    UPDATE
    tested new SS install on dev.clickheredigital.co.uk - worked fine with image_gallery

    deleted the DB and uploaded DB that ive been having problems with and it failed. so guess that isolates the problem to the DB...

  • Platypus
    Avatar
    Community Member
    43 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    I'm getting this error too - using SS 2.3.8 and the latest 2.3 Branch ImageGallery, DOM and SWFUpload.

    In an attempt to repair this - I believed in a file permission problem - I tested around with the assets and image-gallery folder permissions and even renamed the image-gallery folder. Now I can't see the existing published galleries anymore and in the CMS all gallery images are 'grey symbols'! Does someone know how to fix this?

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    any news on this UC?

    9018 Views
Page: 1 2 3 4 5 6 7
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.