Jump to:

7940 Posts in 1543 Topics by 946 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » ImageGalleryPage - Error Saving Content

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5 6 7
Go to End
Author Topic: 9234 Views
  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    ah...sorry UC, that was the wrong error code.
    My partition overloaded with a backup, thats been resolved now though. nothing to do with the current image_gallery issues.

    sorry again (must read before posting!)

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    this was the error email i was receiving (i think!)

    Error: Uncaught Exception: Cannot move /var/www/vhosts/clickheredigital.co.uk/subdomains/ace/httpdocs/assets/image-gallery/Roofing-Photo-Gallery-2/ to /var/www/vhosts/clickheredigital.co.uk/subdomains/ace/httpdocs/assets/image-gallery/Roofing-Photo-Gallery-2/
    At line 403 in /var/www/vhosts/clickheredigital.co.uk/subdomains/ace/httpdocs/sapphire/filesystem/File.php

  • wilhelm oder wil er nicht
    Avatar
    Community Member
    16 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    anyone found a solution? maybe this error helps. if I create an ImageGalleryPage, I've got a javascript error while saving and after that:

    Fatal error: Class 'ImageUploadField' not found in .../image_gallery/code/ImageGalleryAlbum.php on line 27

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    my problems seemed to just go away on their own!
    i wonder if it was more of a server error than an SS error....
    sorry i cant be of more help!

    FYI - I'm now using the latest 2.4.2 version of SS and its all working nicely.

  • wilhelm oder wil er nicht
    Avatar
    Community Member
    16 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    your errors just disappeared without any interaction? nice... why does it not always work like that? ;)
    well I tried it with different SS versions (incl. the newest one) but it makes no difference...
    I'm just using old versions of DOM and ImageGallery now, this seems to work... not the best solution but good for now..

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    line 27 is the cover image upload field...
    have you got the right permissions set?

    i had loads of image upload issues until i set my assets folder (AND all subfolders) to 777.
    that fixed a lot of issues...

  • wilhelm oder wil er nicht
    Avatar
    Community Member
    16 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    Yeah, true. JavaScriptError disappeared. Error Saving Content still there...

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: ImageGalleryPage - Error Saving Content Link to this post

    is it installed on a subdomain or top level?

    9234 Views
Page: 1 2 3 4 5 6 7
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.