Jump to:

7939 Posts in 1543 Topics by 946 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » Uploadify and ImageGallery

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 6188 Views
  • Christy
    Avatar
    Community Member
    57 Posts

    Uploadify and ImageGallery Link to this post

    I am using SS 2.4.2, ImageGallery 493, DOM 504 and Uploadify.

    I had a site ready to go live with working photo albums. There were difficulties uploading so after reading the forum I downloaded Uploadify.

    All downhill from there! Uploadify appeared to upload new files correctly but then showed an HTTP error and didn't display a thumbnail. If I tried to load files through Files and Images, the albums displayed the grey missing image icon. There were also miscellaneous other errors - unable to save pages, unable to delete albums and folders in Files and Images.

    I removed the imagegallery module and deleted all imagegallery tables from the database, flushed and reloaded a fresh copy of the module.

    I can now delete the old F&I folders but the HTTP error is still there. When a new album was created it also created in the database a new_imagegallerypage folder and a page-0 folder. Still getting the missing image icon.

    Could it be something to do with paths?

    Can anyone point me in the right direction please? Many, many hours later am desperate to go live! Thanks.

  • Plato
    Avatar
    Community Member
    26 Posts

    Re: Uploadify and ImageGallery Link to this post

    Hi there Christy,

    The ImageGallery module(s) have not been updated for some time so far as I know (it's been quite some time since I last looked at them). Our resident tanker Frank has worked on his own gallery class using the DOM module.

    http://deadlytechnology.com/silverstripe/silverstripe-image-gallery/

    This blog entry will guide you through the process

    But as to your upload issues, it sounds similar to one we had with swfupload. It's to do with mod_security, and can be passed with a few lines in the .htconfig for your site.

    The details again are covered in Frank's tutorial above, but for speeds sake:

    <IfModule mod_security.c>
       SecFilterEngine Off
    </IfModule>

    If it's not a permissions issue, then it could be a memory issue (reaching the limit while GD tries to resize your uploaded images).
    This line in your .htaccess should help

    php_value memory_limit 128M

    Hope this helps.
    (I realise it's probably a bit late, but someone else may be having a similar issue and searching for an answer... it's how I found your post).

    6188 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.