Jump to:

7937 Posts in 1537 Topics by 944 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » Upgrade SS + DOM issues [SOLVED]

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 839 Views
  • chinaski
    Avatar
    Community Member
    26 Posts

    Upgrade SS + DOM issues [SOLVED] Link to this post

    I'm attempting to upgrade a site from 2.4 to 2.4.3. The site relies on DOM (installed rev. 396).

    I have copied the production site to a local instance and did the upgrade from 2.4 to 2.4.3. The first issue that comes up is that I'm getting a $(".DataObjectManager").livequery is not a function in the js console and the add image button opens a new window rather than the thickboxy popup that it was doing previously.

    I saw a post in this forum indicating this error arose because of a dependency change, and that it was fixed in the DOM trunk. So I updated the DOM to the revision available on this site (rev. 515), and now the popup works but I am unable to add images. The uploader indicator just sits there showing "processing" in the box and never does anything else. When I close the popup no image has been uploaded.

    I'm not seeing errors in the logfile.

    I'm obviously postponing the upgrade to 2.4.3 until I can resolve these issues. Help is appreciated.

  • lerni
    Avatar
    Community Member
    80 Posts

    Re: Upgrade SS + DOM issues [SOLVED] Link to this post

    hi

    just to check it out. remove/rename/turn-off the .htaccess in assets and try it again.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Upgrade SS + DOM issues [SOLVED] Link to this post

    Try getting rid of SWFUpload and using the Uploadify module. http://www.leftandmain.com/silverstripe-modules/2010/08/26/uploadify/

    --------------------
    SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com

  • lerni
    Avatar
    Community Member
    80 Posts

    Re: Upgrade SS + DOM issues [SOLVED] Link to this post

    in my case it was not related to DOM nor CTF. not shure if it's the same in your case ???

    since 2.4.3 .htaccess in assets changed and if it's there in it's current form, my hosters servers stops serving stuff from assets.

  • chinaski
    Avatar
    Community Member
    26 Posts

    Re: Upgrade SS + DOM issues [SOLVED] Link to this post

    I have renamed the .htaccess file in assets, to no effect.

    I will try the uploadify module and see if that works.

    Thanks for the replies...

  • chinaski
    Avatar
    Community Member
    26 Posts

    Re: Upgrade SS + DOM issues [SOLVED] Link to this post

    Uploadify seems to be the shiz - worked straight away when I dropped it into the www folder. I will run with that, although it means I have to document and retrain the users who have grown used to the "old" interface.

    Thanks for the assistance Uncle Cheese and your awesome plugins.

  • dacar
    Avatar
    Community Member
    168 Posts

    Re: Upgrade SS + DOM issues [SOLVED] Link to this post

    Hi, i have got the same problem with the .htaccess file after the upgrade to 2.4.3. Only if i delete the .htaccess, i can access files from assets.

    Greetings, Carsten.

    839 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.