Jump to:

7939 Posts in 1472 Topics by 944 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » Error when inserting images in MCE

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 479 Views
  • nekranox
    Avatar
    Community Member
    31 Posts

    Error when inserting images in MCE Link to this post

    I've got that script that e-mails errors to me installed on a SS 2.4.0 customer website. Periodically I'm getting flooded with the same error and I can't get rid of it.

    Error at sapphire/core/Object.php line 724 (http://bizbuild.co.uk/admin/EditForm/field/Events/item/29/assets/Uploads/OSWnew.jpg)

    Error: Uncaught Exception: Object->__call(): the method 'assets' does not exist on 'DataObjectManager_ItemRequest'
    At line 724 in /hsphere/local/home/bizbuild/bizbuild.co.uk/sapphire/core/Object.php

    I've tried my best to deduce the cause, to me it looks like MCE editor is including an image from the SS assets/Uploads folder and is somehow requesting an invalid URL along the way? The MCE editor is set up on the description field for items within a DataObjectManager.

    Please help o' cheesey one.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Error when inserting images in MCE Link to this post

    Do I understand correctly that you're trying to put an HtmlEditorField in a DOM popup?

    479 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.