Jump to:

7935 Posts in 1536 Topics by 943 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » Empty/never loading image gallery

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2431 Views
  • extasey
    Avatar
    Community Member
    14 Posts

    Empty/never loading image gallery Link to this post

    Hi all,

    I have created a few galleries and none of them seem to load the images when you enter them! They get stuck here:

    This is on a pretty much fresh build as something went skewiff on my last build and cause the home page to require authentication and other pages to look different to what they should!

    Thanks in advance,

    Cameron.

  • extasey
    Avatar
    Community Member
    14 Posts

    Re: Empty/never loading image gallery Link to this post

    Also, to add to my issue, I am having trouble uploading photos into other albums. As in, at the back end I am trying to select a new album from the drop menu and it never applies the change once I have selected the next gallery.

    If it helps, I am using FireFox on a mac, and have tried using Chrome.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Empty/never loading image gallery Link to this post

    You've got a Javascript error. Check your console.

  • extasey
    Avatar
    Community Member
    14 Posts

    Re: Empty/never loading image gallery Link to this post

    Okay,

    I have no experience with Java, can you point me in the right direction to solve the problem?

    If it helps, I am using the black candy theme with a modified typography.css, layout.css and custom images.
    Nothing too heavy, just colour values. have been edited.

  • extasey
    Avatar
    Community Member
    14 Posts

    Re: Empty/never loading image gallery Link to this post

    My web console is empty, is this what you were talking about?

  • UncleCheese
    Avatar
    4085 Posts

    Re: Empty/never loading image gallery Link to this post

    If you're using Firefox, you can check the console in Firebug.. if you're in Safari or Chrome, you can use the Web Inspector console.. There's a Javascript error if the images aren't showing. Start removing all your plugins until you find out what's wrong. Sometimes it's because two versions of jQuery have been included simultaneously, for instance..

  • extasey
    Avatar
    Community Member
    14 Posts

    Re: Empty/never loading image gallery Link to this post

    I used the java console in chrome, and it was empty. I then moved to another computer at work, that has a standard image on it (no plugins to browsers) and the images are still not loading.
    I don't think this is a local issue?
    If you would like to have a look, check http://love2cake.net/index.php/gallery/album/celebrations

  • UncleCheese
    Avatar
    4085 Posts

    Re: Empty/never loading image gallery Link to this post

    You have no closing </body> tag.

    </div>

    <p>Copyright &copy; 2007-2008 | Powered by <a href="http://www.silverstripe.org" title="This site runs on the SilverStripe CMS">SilverStripe Open Source CMS</a></p>

          </div>
       </div>
    <script type="text/javascript" src="http://love2cake.net/index.php/sapphire/thirdparty/jquery/jquery.js?m=1299480167"></script></body>
    </html>

    2431 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.