Jump to:

7939 Posts in 1472 Topics by 944 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » Module Install Problems

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 610 Views
  • weisdaclick
    Avatar
    Community Member
    21 Posts

    Module Install Problems Link to this post

    Excuse the simple question but I have an issue here and am banging my head against a wall.

    I have a brand new SS install - version 2.4.7

    So I installed DataObjectManager - reading the documentation I untar a file to /root then flush, all looks ok.

    When I click Files & Images I get: Error: DataObjectManager requires the Uploadify or SWFUpload modules.

    Then I install Uncle Cheese's Uploadify to /root and flush but I still get the same error - same for SWFObject.

    Here is how the root of my filesystem looks:

    ./
    ../
    .htaccess
    .mergesources.yml
    COPYING
    Makefile
    README.md
    assets/
    cms/
    dataobject_manager/
    dependent.modules
    favicon.ico
    index.php
    mysite/
    phpunit.xml.dist
    sapphire/
    swfupload/
    themes/
    uploadify/
    web.config

    What am I doing wrong????

  • Dazman1
    Avatar
    Community Member
    30 Posts

    Re: Module Install Problems Link to this post

    Hi

    Did you do a /dev/build before the ?flush=1

    Darren

  • weisdaclick
    Avatar
    Community Member
    21 Posts

    Re: Module Install Problems Link to this post

    Wow, you got it!

    I thought you just had to do a flush - lesson learned.

    Thanks so much!

  • Dazman1
    Avatar
    Community Member
    30 Posts

    Re: Module Install Problems Link to this post

    No worries.

    610 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.