Jump to:

7940 Posts in 1543 Topics by 946 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » New Feature: Audio and Video

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
Go to End
Author Topic: 24723 Views
  • UncleCheese
    Avatar
    4085 Posts

    Re: New Feature: Audio and Video Link to this post

    It's possible you have a really old version of FFMPEG. They didn't add that -vframes flag until r3300 or so. They're up to r4000 or r5000 now, i think.

  • Garrett
    Avatar
    Community Member
    245 Posts

    Re: New Feature: Audio and Video Link to this post

    No, no-- these are two different issues-- I contacted him BEFORE I added the set_ffmpeg_root code which then resulted in the bad flag error. He onl;y knows about the Permission denied error. Apparently I am unable to manipulate the FLV's once they've been uploaded (and therefore create the thumbnails), and that's what he's dealing with. We'll deal with the bad flag after this gets done.

  • Garrett
    Avatar
    Community Member
    245 Posts

    Re: New Feature: Audio and Video Link to this post

    I'm having them upgrade to whatever the latest is as we speak. I'm still at the spot where the files get written to the file table, but are not created in the video_thumbnails folder. All of my permissions are correct now.

  • NARKOZ
    Avatar
    Community Member
    25 Posts

    Re: New Feature: Audio and Video Link to this post

    Please, say where I must put this files? Especially AudioPage.ss

  • UncleCheese
    Avatar
    4085 Posts

    Re: New Feature: Audio and Video Link to this post

    Templates should go in your theme directory, /templates/Layout. Make sure you read the tutorials in the Silverstripe documentation to get up to speed on the basics.

  • UncleCheese
    Avatar
    4085 Posts

    Re: New Feature: Audio and Video Link to this post

    Garret, are you still getting the bad flag after the upgrade?

  • Garrett
    Avatar
    Community Member
    245 Posts

    Re: New Feature: Audio and Video Link to this post

    Yes.

    The essence/crux of my problem here is that, as I said, the imaginary thumbnail files get written to the file table (complete with paths), but are in fact not created in the video_thumbnails folder. What do you think is going on here? I am certain the permissions are correct, and I have confirmed that I have the very latest version of FFMPEG (FFmpeg version 0.5, Copyright (c) 2000-2009 Fabrice Bellard).

    //Garrett

  • UncleCheese
    Avatar
    4085 Posts

    Re: New Feature: Audio and Video Link to this post

    So are thumbnails actually being created? Just in the wrong place? Or are you just getting phantom records in your file table? Do those records have the video_thumbnails/ path?

    24723 Views
Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.