Jump to:

7939 Posts in 1472 Topics by 944 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » Bug Reports

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
Go to End
Author Topic: 44559 Views
  • owaiskl
    Avatar
    Community Member
    16 Posts

    Re: Bug Reports Link to this post

    Hey guys,

    I've been getting the following error when attempting to use the SWFupload in conjunction with the data object manager, a little pop up comes up saying:

    TypeError: Property 'onsubmit' of object #<an HTMLFormElement> is not a function

    I tried many different ways to fix it, including updating DOM to the latest build, then trying to update SWFupload to the latest version or beta, neither of which was recognized by SS or DOM, and so I had to revert back to the last version I had installed, which I don't even know the version number of.

    So, I have a feeling that the bug may not actually be in DOM, but rather in SS or SWFUpload, but if someone could even help translate the error in english to me, maybe I'll be able to fix it. Please and thank you.

    SS. 2.3.4
    DOM r374
    SWFUpload Not sure
    Tried in all browsers, and several operating systems

  • UncleCheese
    Avatar
    4085 Posts

    Re: Bug Reports Link to this post

    I would update your swfupload code to the latest version. There were some javascript fixes that got rolled out a few ticks back.

  • owaiskl
    Avatar
    Community Member
    16 Posts

    Re: Bug Reports Link to this post

    Thanks for your quick response,

    I tried to get the latest swfupload revision, except SS didnt seem to accept the newer one? Is it not just the same installation process (copy the folder to root, change name to swfupload and then dev/build/)? Unless they're some more specific way to update swfupload that I havent been able to figure out in these three hours...

  • UncleCheese
    Avatar
    4085 Posts

    Re: Bug Reports Link to this post

    In the latest rev, there are two properties in the SWFUploadControls class: "$image_class" and "$file_class"

    If you have that, you're on the latest version.

  • owaiskl
    Avatar
    Community Member
    16 Posts

    Re: Bug Reports Link to this post

    I checked it, and it has the $file but not $image_class or $file_class....

    So I need to update swf upload, but dragging and dropping that has refused to work for me?

  • UncleCheese
    Avatar
    4085 Posts

    Re: Bug Reports Link to this post

    I'm not sure what you mean by drag and drop. I usually just pull it down with SVN.

  • owaiskl
    Avatar
    Community Member
    16 Posts

    Re: Bug Reports Link to this post

    By drag and drop I meant I deleted the old swfupload folder through ftp, and then uploaded the new version through ftp again... and I get

    Error: DataObjectManager requires the SWFUpload module.

    instead of the assets page in admin...

    Also, I dont have an SVN client, is there a free one that you recommend? For Mac?

  • UncleCheese
    Avatar
    4085 Posts

    Re: Bug Reports Link to this post

    I can't understand why that would be happening. The directory name is "swfupload", and you're running a ?flush=1 after uploading the new one?

    44559 Views
Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.