Jump to:

7939 Posts in 1472 Topics by 944 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » Can't upload to new folders

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 1459 Views
  • joelg
    Avatar
    Community Member
    129 Posts

    Can't upload to new folders Link to this post

    Hi there

    I'm having some troubles creating new folders in the Files & Images tab in the admin section.

    The folder pops up fine, however I can't upload nor import to this folder. I've made chmod 777 on assets folder and all children, but this doesn't fix anything.

    Has somebody had the same problem?

    Joel

  • vstrazz
    Avatar
    Community Member
    63 Posts

    Re: Can't upload to new folders Link to this post

    Make sure the ownership is correct as well.

  • joelg
    Avatar
    Community Member
    129 Posts

    Re: Can't upload to new folders Link to this post

    How do I do this?

  • keeny
    Avatar
    Community Member
    48 Posts

    Re: Can't upload to new folders Link to this post

    you can do

    chown -R owner:group .

  • joelg
    Avatar
    Community Member
    129 Posts

    Re: Can't upload to new folders Link to this post

    Hi Keeny

    Could you please spell it our for me, I really don't know what this means? Is it some sort of cgi-script, or?

    Many, many thanks.

    Joel

  • UncleCheese
    Avatar
    4085 Posts

    Re: Can't upload to new folders Link to this post

    You need to make sure that apache as read/write perms on those folders. I think this is a moot point if you've opened everything up to 777.

    This is unlikely a permissions issue. What do you mean when you say "cannot upload or import"? Is there an error? It sounds like it's coming from Silverstripe, not your filesystem.

  • joelg
    Avatar
    Community Member
    129 Posts

    Re: Can't upload to new folders Link to this post

    Hi UncleCheese

    Screendump 1: This is where I create the new folder - everything looks good

    Screendump 2: This is an upload to the new folder. This should be a regular gif-file, however somethings really not right.

    Screendump 3: This is an import. The filename is right, but there is no image.

    Via my FTP I can see that assets is 777, and so is the new folder. However, there are no files in the folder.

    So, what could cause this. It looks to me like it's a path or something that is not right...?

  • joelg
    Avatar
    Community Member
    129 Posts

    Re: Can't upload to new folders Link to this post

    Oh, and by the way. Import and upload works brilliant in existing folders created locally...

    1459 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.