Jump to:

7939 Posts in 1472 Topics by 944 members

DataObjectManager Module

SilverStripe Forums » DataObjectManager Module » Image uploading not working - javascript error

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2758 Views
  • Viv
    Avatar
    Community Member
    29 Posts

    Image uploading not working - javascript error Link to this post

    Hi,

    Have just created a new site with SS 2.3.3 and have uploaded the latest image gallery modules:

    modules-image_gallery-r314
    modules-dataobject_manager-r320
    modules-swfupload-r271

    All seems to be working until trying to upload an image to an album. Nothing appears in the upload box (ie. no form to upload anything). When I checked the javascript Error Console in Firefox I see the following error:

    Error: illegal XML character
    Source file: http://www.mysite.co.nz/dataobject_manager/javascript/dataobjectmanager_popup.js
    Line: 4, Column: 1
    Source code: <<<<<<< .mine

    I have other (earlier) installations of the Gallery working OK on other sites (excellent module by the way!). Any help here would be appreciated.

    Thanks.

  • Platypus
    Avatar
    Community Member
    43 Posts

    Re: Image uploading not working - javascript error Link to this post

    After updating to DOM r320 I get the same issue, nothing appears inside the upload box.

    And I had to set "allow_assets_override" to "false" because I ran into this, when I tried to go to "Files & Images":

    Fatal error: Out of memory (allocated 30408704) (tried to allocate 4864 bytes) in .../sapphire/core/Object.php(665) : runtime-created function on line 1

  • Viv
    Avatar
    Community Member
    29 Posts

    Re: Image uploading not working - javascript error Link to this post

    Tried changing the "allow_assets_override" to "false". I can now use the "files and images" section to upload files now with the normal upload system. However these files are not linked in to the image gallery so do not appear in there or on the final image gallery pages.

    Still getting the empty box with the image gallery "upload photos" section...

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image uploading not working - javascript error Link to this post

    Yikes... looks like an SVN conflict somehow worked its way into the trunk. Run another update and you should be good.

  • Viv
    Avatar
    Community Member
    29 Posts

    Re: Image uploading not working - javascript error Link to this post

    Sorry, do you mean get and install the latest version (DailyBuild?) of the SS Core?

    PS: Just added to my original post that it says the error is: "illegal XML character"

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image uploading not working - javascript error Link to this post

    No, update your DataObjectManager SVN.

  • Viv
    Avatar
    Community Member
    29 Posts

    Re: Image uploading not working - javascript error Link to this post

    Thanks very much, did that and all good!

  • Platypus
    Avatar
    Community Member
    43 Posts

    Re: Image uploading not working - javascript error Link to this post

    Thanks UncleCheese, DOM r322 fixed the upload box.

    But I still can't use "allow_assets_override". If I set this to "true" I can't access my Files & Images, resulting in in out of memory errors like the one posted above.

    Or like this:

    Fatal error: Out of memory (allocated 30408704) (tried to allocate 19456 bytes) in .../sapphire/forms/TreeDropdownField.php on line 98

    Fatal error: Out of memory (allocated 30408704) (tried to allocate 48 bytes) in .../sapphire/core/Object.php on line 580

    Thanks for you're help! Platypus

    2758 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.