Jump to:

2076 Posts in 857 Topics by 449 members

E-Commerce Modules

SilverStripe Forums » E-Commerce Modules » NEED HELP

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Page: 1
Go to End
Author Topic: 857 Views
  • Nickt
    Avatar
    Community Member
    43 Posts

    NEED HELP Link to this post

    i have 5 problems, if you can help for any of them, that would be much appreciated.
    1. When i set up variations and click on 'add to cart' a white page comes up with the url 'www.mysite/product/add'
    2. When a product is in the shopping cart, the name of the product is #0
    3. When i click 'go to the checkout' (the link that replaces the add to cart link) i get directed to my homepage
    4. When somebody purchases something, i do not get an email notification
    5. When trying to remove anything from my cart, nothing happens

    Thanks so much for any help

  • Kalileo
    Avatar
    Community Member
    127 Posts

    Re: NEED HELP Link to this post

    Nickt, you might want to make it easier to help you by adding same basic info, such as:
    - SS version
    - E-Commerce version
    - Templates used (the ones coming with e-commerce or blackcandy or old ones from a Theme)?

  • Nickt
    Avatar
    Community Member
    43 Posts

    Re: NEED HELP Link to this post

    sorry, i am using ecomerce 0.6 beta and ss 2.3.3 with the template 'oldenglish' if you want to have a look feel free to go to http://www.thirteen.co.nz

    thanks

  • Kalileo
    Avatar
    Community Member
    127 Posts

    Re: NEED HELP Link to this post

    Most of the issues you describe sound like template issues. let me explain:

    There are different templates for each part which can be used, such as the product list, the product page, the shopping cart. In order to use the new ecommerce version you should not use a template which was built for an older ecommerce version. Too much has changed in ecommerce recently. Many of themes which have their own templates for ecommerce had been built some time ago, so if they contain ecommerce templates, then they fit for the older ecommerce versions.

    Now your oldenglish theme was released 03 Sep 08, and it says that it is compatible with ecommerce, thus I assume that it contains its own templates for ecommerce. If so, they can only be written for an ancient version of ecommerce. In this case replace the oldenglish_ecommerce templates with the generic templates from the ecommerce module. You might need to adapt them to fit your oldenglish theme, use the old oldenglish templates as samples.

    If your oldenglish theme does not contain its own ecommerce templates then check what templates are used, and make sure they are the ones from your version of ecommerce.

  • Nickt
    Avatar
    Community Member
    43 Posts

    Re: NEED HELP Link to this post

    if i deleted the oldenglish ecommerce files, would the ecommerce 0.6 files be used instead?

  • Nickt
    Avatar
    Community Member
    43 Posts

    Re: NEED HELP Link to this post

    STILL NEED HELP!!!

    857 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.