Jump to:

2087 Posts in 1007 Topics by 455 members

E-Commerce Modules

SilverStripe Forums » E-Commerce Modules » Working on e-commerce for SS 2.4

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
Go to End
Author Topic: 13275 Views
  • CHD
    Avatar
    Community Member
    218 Posts

    Re: Working on e-commerce for SS 2.4 Link to this post

    never mind i got it working...not sure what went wrong still though!
    i resorted to downloading ecommerce & payments again then re-applying my css and fixes. it all works fine now.

    the only problems i have now are:
    emails confirmations are sent twice (immediately), and always say "incomplete" yet if i press the back button to paypal recipt page, then follow the link through to mysite again, the emails are sent again with "success"? maybe the other ones are being sent too quickly and paypal doesnt have a chance to confirm the payment or something?

    the other problem is stock control, i cant see any way to do it?!
    is it not included?
    i also see the "number sold" column is always "0"?
    lastly, unchecking the "allow product to be purchased" box seems to do nothing.

    im about to hand this site over to client and these seem like basic features that are missing

    can anyone shed any light on this?
    thanks!

  • wainui
    Avatar
    Community Member
    56 Posts

    Re: Working on e-commerce for SS 2.4 Link to this post

    yep.. I am getting incomplete too..
    wierd as checked the database and set in database as 'success'.. and shown on site as success.. just the email incorrect.

    as for the other features you looking for you will have to try and fix/add them yourself. This is an work in progress so dont expect everything to work out of the box.

  • wainui
    Avatar
    Community Member
    56 Posts

    Re: Working on e-commerce for SS 2.4 Link to this post

    Has anyone else had problems with a error on return from paypal?
    I also get a blank white page (paypal/complete)

    I have been checking this out and seems to be related to paypal itself.
    When I view the site on a newer PC using firefox I get a new version of paypal (using jqeury or similiar).
    This version of paypal fails on return but same code is ok on the other 6 computers I have tried (all using non js version of paypal site).

    Anyone experienced this?

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: Working on e-commerce for SS 2.4 Link to this post

    Not sure about older versions, but my white screen of death was caused by some amends i had made to one of my php or template files i think! I downloaded ecommerce and payments again and that fixed it. Although i havent tried it in older browsers

  • wainui
    Avatar
    Community Member
    56 Posts

    Re: Working on e-commerce for SS 2.4 Link to this post

    It doesnt seem to be older browsers.. On one particular machine I am getting a new version of paypal (with animated jquery style ajax page loading). I have never seen this version of paypal, of course it is on clients machine And it fails at the paypal/complete screen.

    Going to get here computer for the night so will try and figure out what the problem is...

  • wainui
    Avatar
    Community Member
    56 Posts

    Re: Working on e-commerce for SS 2.4 Link to this post

    If anyone else has the problem described above...
    i tracked down that paypalwas returning

    //contents of $_REQUEST
    url = /silverstripe/paypal/complete
    PastMember = 1
    BlogHolder_Name = Mike...
    PHPSESSID = tni3m1vt...
    _utma = 88101....
    _utmz = 88101....

    So obviously the complete function will not fire as it is missing all the usual paypal return values!!!!
    I fixed this by deleting allpaypal cookies from the computer and it works ok know.
    If anyone has any idea why this would happen any insight would be greatly appreciated.

    As I mentioned earlier I was getting a new version of paypal using jquery ajax like functionality.

    I am wondering if it was a setting inside paypal of my clients? As same computer when tested of sandbox was ok and showed normal paypal page.

  • CHD
    Avatar
    Community Member
    218 Posts

    Re: Working on e-commerce for SS 2.4 Link to this post

    maybe your client has their checkout process switched to "paypal advanced" rather than paypal standard?
    (its the version thats a bit more flash!) not sure of the exact names...

  • wainui
    Avatar
    Community Member
    56 Posts

    Re: Working on e-commerce for SS 2.4 Link to this post

    Not sure if this is a bug or I just am not that familiar with silverstripe yet...

    I have a test product that I had set to 1 cent while testing.
    I have now changed it back to the actual price of $170 which is reflect in product page correctly but when added to cart still has old price of 1 cent!

    I have emptied cache done dev/build flushed etc but still showing in cart as 1 cent.

    Any ideas?

    13275 Views
Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.