Jump to:

2082 Posts in 1002 Topics by 452 members

E-Commerce Modules

SilverStripe Forums » E-Commerce Modules » error setting up ecommerce with 2.4

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Page: 1
Go to End
Author Topic: 866 Views
  • servalman
    Avatar
    Community Member
    211 Posts

    error setting up ecommerce with 2.4 Link to this post

    Hello

    I've been trying for test purpose to set up ecommerce working with 2.4.
    usually I don't have problem to set up module.

    I followed the instruction on the google project page but I got this error :

    Fatal error: Object::add_extension() - Can't find extension class for "EcommerceRole" in /var/www/vhosts/possibles.net/httpdocs/silvertests/sapphire/core/Object.php on line 526

    I think I don't have have the right trunk but the link (http://silverstripe-ecommerce.googlecode.com/svn/trunk/silverstripe-ecommerce-read-only) doesn't work.

    So my questions are :

    Can someone provide me with the latest trunk of the 0.6 version of ecommerce.?

    also in the installation instruction there is some code lines that have to be added to _config.php file I guess it is "mysite/_config.php" ?

    Thank for answering those questions.

    Thomas

  • Bambii7
    Avatar
    Community Member
    254 Posts

    Re: error setting up ecommerce with 2.4 Link to this post

    Hi servalman
    have you tried downloading from this link? http://silverstripe-ecommerce.googlecode.com/svn/trunk/
    Its on the download page of the Google project.
    Putting the settings in mysite/config.php worked for me.

    866 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.