Jump to:

2081 Posts in 1001 Topics by 452 members

E-Commerce Modules

SilverStripe Forums » E-Commerce Modules » E-Commerce claims older support for 2.3 but requires Payment module which doesn't work for 2.3

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Page: 1
Go to End
Author Topic: 419 Views
  • bostonmark
    Avatar
    Community Member
    10 Posts

    E-Commerce claims older support for 2.3 but requires Payment module which doesn't work for 2.3 Link to this post

    Hi all,

    I'm running a site on SilverStripe 2.3.11 and would like to use the E-Commerce module. The module has an older release that would satisfy my version requirement:

    Version: [v0.6.1]
    Date: 2009-06-18
    Compatible with: SilverStripe 2.3
    Download: ecommerce-0.6-beta2.tar.gz

    I tried to install this but got an error about Payment not existing. The E-Commerce module claims it requires the Payment module as well. Fine by me, so I tried to find a release of the Payment module that works on SilverStripe 2.3.11 but no releases listed show that kind of support. My ultimate question is, how can the E-Commerce module work for 2.3 if there's no Payment module that works with 2.3? Am I missing something?

    I appreciate any help you can provide. Thanks in advance.

  • Ryan M.
    Avatar
    Community Member
    309 Posts

    Re: E-Commerce claims older support for 2.3 but requires Payment module which doesn't work for 2.3 Link to this post

    You can try installing it anyways. If anything's wrong with it you could just get your hands dirty and fix it yourself, if you're programatically inclined.

    419 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.