Jump to:

2076 Posts in 857 Topics by 449 members

E-Commerce Modules

SilverStripe Forums » E-Commerce Modules » Ecommerce version

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Page: 1
Go to End
Author Topic: 661 Views
  • martbarr
    Avatar
    Community Member
    41 Posts

    Ecommerce version Link to this post

    Just downloaded v3 into a 2.4.8 working site, and am getting
    PHP Fatal error: Class 'DataExtension' not found in /var/www/*/ecommerce/code/model/extensions/EcommerceRole.php

    I thought v3 of ecommerce was compatible with 2.4+
    or is there something else I should look at ?

    thanks
    Martin

  • Jedateach
    Avatar
    Forum Moderator
    227 Posts

    Re: Ecommerce version Link to this post

    The 'DataExtension' error means that you've got a silverstripe3 version of the ecommerce module. You should try and find a 2.4 branch.

  • martbarr
    Avatar
    Community Member
    41 Posts

    Re: Ecommerce version Link to this post

    thanks - thought so - just that the module download page for ecommerce v3 does actually say 2.4+ which threw me a bit.
    Will go and find the right version.

    Cheers
    Martin

  • HansR
    Avatar
    Community Member
    140 Posts

    Re: Ecommerce version Link to this post

    @martbarr

    Try version 2 (or 1). Version 3 is a WIP to update the ecommerce module to Silverstripe 3. I guess that the docs are out of date.

    Hans

    661 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.