Jump to:

2076 Posts in 857 Topics by 449 members

E-Commerce Modules

SilverStripe Forums » E-Commerce Modules » Need Help? install problem?

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Page: 1
Go to End
Author Topic: 984 Views
  • Thermalzombie
    Avatar
    Community Member
    27 Posts

    Need Help? install problem? Link to this post

    Hi trying to install copied ecommerce to following these instructions:

    1. Unzip this file (ecommerce-0.5.tar.gz) inside your SilverStripe installation directory.
    It should be at the same level as 'jsparty', 'themes' and 'sapphire' modules.

    2. Ensure the directory name for the module is 'ecommerce'.

    3. Visit your SilverStripe site (you require 2.0.2+ to operate this module).

    4. Add db/build to the end of the website URL. For example: http://localhost:8888/mysite/db/build.

    My website is: http://www.thermalzombie.com/

    And I now have this error:

    Website Error
    There has been an error

    The website server has not been able to respond to your request.

    I have tried putting db/build on the end of my website link but didnt work and I dont understand how it is supposed to when I cannot even find a directory on my website called db.

    Yes I am a noob and probably stuffed up somewhere please help any reply welcome.

    version information:
    SilverStripe (Version 2.3.2)
    E-Commerce [v0.5.2] (somebody forgot to update the version number in the install instructions it says Module 0.5.1 beta)

    Attached Files
  • banal
    Avatar
    Community Member
    901 Posts

    Re: Need Help? install problem? Link to this post

    Hi.
    The URL changed from db/build to dev/build in SilverStripe 2.3+
    You have to be logged in to the CMS to run dev/build

  • Thermalzombie
    Avatar
    Community Member
    27 Posts

    Re: Need Help? install problem? Link to this post

    How do I log in if I have an error do you have to upload the files while you are still logged in?

  • banal
    Avatar
    Community Member
    901 Posts

    Re: Need Help? install problem? Link to this post

    Try: dev/build?isDev=1
    Update Just did that for you.. should work now

  • Thermalzombie
    Avatar
    Community Member
    27 Posts

    Re: Need Help? install problem? Link to this post

    Thankyou your awesome.

    984 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.