Jump to:

2088 Posts in 1008 Topics by 455 members

E-Commerce Modules

SilverStripe Forums » E-Commerce Modules » Paypal Integration NOT working...

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba, simon_w

Page: 1 2 3 4
Go to End
Author Topic: 6617 Views
  • Dynamic
    Avatar
    Community Member
    16 Posts

    Re: Paypal Integration NOT working... Link to this post

    Upgrading to 2.3.3rc2 worked for me as well. Still had to do quite a bit of hacking around with info I found in the forum, but the SS upgrade fixed the original problem I was having.

    Thanks for the help everyone!

  • Patrick
    Avatar
    Community Member
    11 Posts

    Re: Paypal Integration NOT working... Link to this post

    I imagine I'm missing a step here, but is there anything I need to do to make the "order complete" page show that payment through paypal was successful? As it is now it shows "Failure", even though the transaction went through.

    Thanks,

    P.

  • ryanwachtl
    Avatar
    Community Member
    46 Posts

    Re: Paypal Integration NOT working... Link to this post

    Patrick,

    I was able to complete a PayPal payment and SilverStripe recorded the payment as 'Order Successful' in Admin Reports and 'Success' in Payment Status under Customers Account.

    I will play around with more this evening and see if I can reproduce a 'Failure' in Payment.

  • ryanwachtl
    Avatar
    Community Member
    46 Posts

    Re: Paypal Integration NOT working... Link to this post

    Patrick,

    Sounds like the Payment is not coming back as 'Completed' when returning from PayPal.

    I could only duplicate this by completing a transaction in sandbox.paypal with a test account that had 'Payment Review' set to 'enabled'. It should complete if this is changed to 'disabled'.

    Not sure if this helps you at all. Are you using a live account or a test account in the sandbox?

  • Patrick
    Avatar
    Community Member
    11 Posts

    Re: Paypal Integration NOT working... Link to this post

    Hmm... interesting... all of a sudden Wamp's Apache server started to crash on returning from PayPal (sandbox). After trying a couple of different things I updated my Wamp server to the latest version and now it works perfectly, including showing successful transactions.

    Thank you, Web Architect, for the time you put into this. I really appreciate it and your input!

    P.

  • datago
    Avatar
    Community Member
    5 Posts

    Re: Paypal Integration NOT working... Link to this post

    updating to silverstripe 2.3.2rc4 didn't make any difference to my situation
    i haven't tried with anything other than a live account
    not really sure where to go from here

    any other suggestions??

    thanks!

  • ryanwachtl
    Avatar
    Community Member
    46 Posts
  • Patrick
    Avatar
    Community Member
    11 Posts

    Re: Paypal Integration NOT working... Link to this post

    You should also sign up for a sandbox paypal account to do your testing:

    http://developer.paypal.com

    You can create any number of any kind of accounts that will not do real transactions but will interact with SilverStripe (or any other application) the same way live accounts would.

    Good luck,

    P.

    6617 Views
Page: 1 2 3 4
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.